Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to connect a Windows XP machine to the Internet via my router / ADSL modem at home. When I set up a dialup connection, the machine is able to resolve external domain names. When I just plug it in without dialling up, it will not resolve the names. It can resolve names of other machines internal to the network, and other machines can ping it. It can ping the router and external IPs without needing to dial up.

The router and network are absolutely fine for 4 other machines on the network - Windows 7 and Linux boxes, as well as my Android phone, none of which require dial-up connections.

The same behaviour occurs regardless of whether the firewall is on or off.

EDIT: Everything works when I hardcode in the correct default gateway and DNS server. When I leave all the stuff blank, it breaks again.

share|improve this question

You could check your IP settings to make sure that you've got DHCP set up for your DNS server, not something hardcoded in there.

share|improve this answer
Does this config live somewhere other than the usual Connection Properties -> TCP/IP settings? There's nothing there that is hardcoded. When I do hardcode in the correct default gateway / DNS server, it does work. – Fritz Meissner Apr 21 '11 at 10:52
No, it should live in the usual place. With them not hardcoded if you do ipconfig/all at a command prompt you can see if the gateway/dns server are being correctly given out by your router. – paulmorriss Apr 26 '11 at 9:49

Check if the default gateway in working machine is same as windows xp. I think it will be not. Then adjust your default gateway to be that same as working machine if possible. To print the routing table in windows xp., Open cmd prompt and type

route print

look for default section in near end of the list. I think this cmd requires admin privileges. Please check. For linux

#route -n


share|improve this answer
To be honest, I'm not 100% certain how to read this, but it does look similar for the two. – Fritz Meissner Apr 21 '11 at 10:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.