Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to install MS Exchange 2010 on Windows Server 2008 R2. The installation went fine i.e. the wizard went through the process successfully.

Now when I run the get-exchangeserver inside the EMS get the following error. Any help will be highly appreciated.

PS C:\Users\administrator.ROOT> Get-ExchangeServer
The term 'Get-ExchangeServer' is not recognized as the name of a cmdlet, function, 
script file, or operable program. Check the spelling of the name, or if a path was
included, verify that the path is correct and try again.
At line:1 char:19
+ Get-ExchangeServer <<<<
    + CategoryInfo          : ObjectNotFound: (Get-ExchangeServer:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException
share|improve this question

migrated from Apr 7 '11 at 10:37

This question came from our site for professional and enthusiast programmers.

Have you rebooted after the installation finished? – HostBits Apr 7 '11 at 12:00

More of a server thing I'd say, in any case...

Anonymous: Chances are you're running the script from a PowerShell prompt, instead of the Exchange Management Shell. Run the script from EMS and it should work.

(From comment in

Happy admin stuff.

share|improve this answer
Not quite, I am running it from EMS. – Sanj Apr 7 '11 at 9:23
up vote 0 down vote accepted

I figured it was the IIS the stopped due to conflict with protocols. it kept shutting it down for some weird reason it is when i stopped sharepoint web service when it started working.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.