Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have tried installing versions 5.5.11 and 5.1.56 of the MySQL Community Server DMG on my new MacBook Pro 2GHz Intel Core i7 running OS X 10.6.6.

It claims that installation is successful, and the Preference Pane window claims that the server is running, but I can't run 'mysql' commands in the Terminal, nor does any MySQL related process show in the Activity Monitor. Can anyone help?

I tried the answer given here, but still no action.

Mysql wont start on Mac OSX?

Thanks in advance, Matt

share|improve this question

Add MySQL's bin folder to the path (e.g. in .bash_profile):

export PATH=/usr/local/mysql/bin:$PATH
share|improve this answer
  1. Make sure the Activity Monitor is filtering for 'All Processes', 'mysqld' will be displayed, otherwise your Pref Pane woudln't show it.

  2. Type this at your console, to link the mysql client to your /usr/bin

sudo ln -s /usr/local/mysql/bin/mysql /usr/bin/mysql

Good location for downloads:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.