Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My apache server sends a "Request Entity too Large" error, when I am trying to upload a file. This happens when the actual "post body" is sent by the client after about 10 seconds of sending the "request header". Is there any way to disable this on Apache.

share|improve this question

3 Answers 3

There's a method using mod_security, assuming you don't mind making it much larger:

You can also limit the size of the HTTP request body data. This is very handy for disabling large data in HTTP POST requests.

SecRequestBodyLimit 10485760

This is probably worth a read about any consequences of such a change: Mod Security HOWTO

share|improve this answer
    
Was looking for a reason why for hours and completely forgotten about enabled mod_security and its directives! Thanks! –  Ilia Rostovtsev Jan 21 at 11:16
up vote 1 down vote accepted

I found the answer. There is a Apache setting for this:

RequestReadTimeout

More can be found at:

http://httpd.apache.org/docs/2.2/mod/mod_reqtimeout.html

share|improve this answer

If you're using PHP on the server to upload the file, you might want to look in your apache configs for something that looks like "LimitRequestBody" or other restrictions on the size of the data allowed for upload. post_max_size is another thing to look for in php.ini, along with upload_max_filesize

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.