Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In a nutshell:

  • SBS03 server with Backup Exec 12 installed.
  • Two USB drives, each 1TB.
  • USB drives are swapped weekly.

A weekly full backup and 4 days of subsequent backups just about fills a drive. After swapping a drive, the next Weekly Full job will throw an alert about low space and we have to manually clean out the drive so that the backup will finish. I know there's a way to dial this in so that Backup Exec will manage that space for us, but I can't seem to hit the right settings!

The media set properties for "media set periods" are currently at:

  • Overwrite protection period: 13 days
  • Append period: 1 hour

The weekly job is set to "Append to media, overwrite if no appendable media is available"

[added later] Tools -> Options -> Media Management had "media overwrite protection" at the default "Partial" setting.

What other settings am I missing to get this working without intervention?

share|improve this question
    
Under the 'Media' tab in Backup Exec, take a look at the media sets that are allocated on those backup-to-disk folders. Are any of them listed as 'Overwriteable' even though the jobs are complaining about no media available? If so, you're hitting the exact same problem I am right now, and I'm planning log a call with Symantec next week... –  Chris Thorpe Apr 10 '11 at 1:51
    
Yeah, they're now at 8 days overwrite protection / 1 hour append period. –  Chris_K Apr 10 '11 at 3:40

2 Answers 2

up vote 2 down vote accepted

Sounds to me like your Overwrite Protection Period is the culprit.

Have you tried lowering the threshold on that value? For what it's worth, I utilize that value only to be sure that I don't mistakenly overwrite a particular backup. In your case, that would be 8 days. (Assuming you always do the full on the same day of the week).

I have found that the protection periods are really draconian in their calculations, so keeping it shorter is better. With 8 days, you will still ensure that the second week doesn't overwrite the first, but you should also be safe from it forcing you not to be able to overwrite. (For what it's worth, I am fairly certain that the overwrite period begins at the time the backup job completes)

The "Append to media, overwrite if no appendable is available" setting merely tells BE to err on the side of saving the data if it's possible, but that setting will not allow you to overwrite something that is still in overwrite protection.

Hopefully this helps some, and if not, let me know and I will see what else I can come up with.

share|improve this answer
    
Ahh... "I am fairly certain that the overwrite period begins at the time the backup job completes." That may be the issue. I'll try your suggestion of 8 days (or anything less than 13 really (weekly takes over 12 hours). –  Chris_K Apr 7 '11 at 15:10
    
+1. It sounds to me like the overwrite protection settings are the culprit. The overwite protection is calculated based on the modified date, not the allocated date so in this case 13 days is too long. The overwrite settings need to be calculated from the last date that a backup is performed on that particular piece of media. –  joeqwerty Apr 7 '11 at 15:15
    
I'll know tomorrow :-) –  Chris_K Apr 8 '11 at 17:06
    
... Nope, changing from 13 to 8 days didn't do anything for me. I've now visited Tools -> Options -> Media Management and changed it "Media Overwrite Protection level" from Partial to None. –  Chris_K Apr 10 '11 at 0:55

Are the backup sets contained on second drive created more than 13 days ago when you connect it to be used? If not then drive will appear appear as full (based on the fact that you stated the full backup and four days worth of backups fill the drive). You may need to lower the overwrite protection period.

share|improve this answer
    
Yes, they weekly runs every 7 days, same as the drive rotations. So... in theory... the jobs should be 14 days old. However, if the timer starts when the weekly job finishes then my times are off by a day. –  Chris_K Apr 7 '11 at 15:13
    
I would change your overwrite period to 12 days then and see if that solves it. You don't want to set it too low and end up overwriting data sets you might need. –  Cheekaleak Apr 7 '11 at 15:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.