Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I was trying to install .NET 3.5 SP1 to one of our production machines with Windows 2003 SP2. However, the installer just hang at around 80% with message "Setup is loading installation components, This may take a minute or two". In fact it's been like that for 30mins already and using 0% CPU.

I disabled the anti-virus software and then applied the windows installer 4.5 update but no luck, the installer still hangs.

Anyone had this problem before?

share|improve this question

13 Answers 13

I can't speak to your specific problem, in a similar situation I would suggest using Process Monitor to see what happens when you run the installer a second time.

  1. Cancel the install.
  2. Start process monitor.
  3. Run the installer capturing event.
  4. Stop the trace after 5-10 minutes of nothing happening.
  5. Go through the log and filter out anything that isn't related

Googling for process and file names, will help you identify what isn't related.

share|improve this answer
    
thanks for the suggestion, I'll give it a try –  Oscar Kuo Jun 15 '09 at 18:58

There are reports of users who claim that deactivating the network adapter solved the issue. I am aware that this is not a good solution for a production server.

I've also heard that real-time antivirus software can slow down the installation.

share|improve this answer
    
Hi, yes I did disable the antivirus scanner, which had significantly improved the installation speed. However, it still stuck at 80% with message "loading installation components" –  Oscar Kuo Jun 15 '09 at 18:59

Seriously either disabling the network adapter or pulling the ethernet seem to work for this issue. I have come across it recently, frustrating as all get out, but that was the answer.

share|improve this answer
    
But what if you're on a remote vm server in a dark datacentre somewhere? It's very annoying. –  Iain Holder Mar 16 '10 at 16:37
1  
Yes, this works like a charm, it seems as if the .NET installer is trying to phone home, fails with long timeouts and retries. –  Chris O Aug 7 '10 at 14:55

I agree about the network thing; I think the installer does... something with Microsoft servers, and sometimes that doesn't work and the installer hangs. Everytime that happened to me, disabling the network adapter allowed the setup to continue gracefully.

share|improve this answer

I finally found a way to do it:

http://blogs.msdn.com/astebner/archive/2008/07/17/8745415.aspx?CommentPosted=true#commentmessage

After extracting the full installer and also within there the other installer and putting the language ENU switch in place (and not using the /web switch) all went smooth and fine!!

share|improve this answer

Disable proxy settings in IE. That is all that has to be done.

share|improve this answer

I really don't think disabling network is the right solution. I would prefer looking at the .net installation logfile located at C:\WINDOWS\Microsoft.NET\Framework\v3.5\Microsoft .NET Framework 3.5 SP1\Logs and verify at what stage the installation has hung. The installer is hardly about 70 MB in size and should not take long time to download either. I have always run Windows Update to install all the necessary update but have never faced any issues when using WSUS or stand-alone installer.

Yes, Aaron's blog pointed out by Eleasar is also the right step to follow.

share|improve this answer

Dont disable network. Try IE Connection setting and choose not to use any proxy or proxy settings file. Worked for me on Windows server 2003.

share|improve this answer

Blockquote

Dont disable network. Try IE Connection setting and choose not to use any proxy or proxy settings file. Worked for me on Windows server 2003.

Blockquote

Same here for me, Disabling IE proxy allowed the install to complete.

share|improve this answer

Stupid MS, sending installer in a deadlock. They should have thought abt this, many use proxy. I just disabled and re-enabled network adapter. Went fine after that.

share|improve this answer

Clear proxy settings ipconfig /flushdns Remove the gateway IP address from your LAN adapter Remove the DNS sever IP from the LAN adapters

This prevented any lookup or network attempts from getting any name resolution or anyting but a destination host unreachable. Worked for me.

share|improve this answer

For those like me searching for an answer and stumbling upon this, what worked was

  1. Downloading the full installer package, not the web one
  2. Don't know if it helped, but I added the registry entries from the post above
  3. Disabling the proxy in IE
  4. Running from the command line and adding /lang:ENU
share|improve this answer

Are you using Full Package (Offline) installer? http://www.microsoft.com/en-us/download/details.aspx?id=25150

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.