Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How can I see how the OpenLDAP executable provided by my distribution (OpenSuSE) was compiled ?

After long debugging, I think that my TLS config is simply ignored. I would like to check if slapd was compiled with --with-tls or not. Is there any way to see what is compiled into the executable ?

slapd -VVV only shows overlays and backends, but tells me nothing about TLS.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Looking in the source RPMs from http://download.opensuse.org/repositories/network:/ldap:/OpenLDAP:/RE24/openSUSE_11.2/src/

The openldap2-2.4.25-141.1.src.rpm gives this for the build configuration in the openldap2.spec file.

%configure \
        --localstatedir=/var/run/slapd \
        --libexecdir=/usr/lib/openldap \
        --enable-wrappers \
        --enable-spasswd \
        --enable-modules \
        --enable-shared \
        --enable-dynamic \
        --with-tls \
        --with-cyrus-sasl \
        --enable-crypt \
        --enable-ipv6=yes \
%if "%{name}" == "openldap2"
        --enable-aci \
        --enable-bdb \
        --enable-hdb \
        --enable-rewrite \
        --enable-ldap=yes \
        --enable-meta=mod \
        --enable-monitor=yes \
        --enable-perl=mod \
        --enable-sql=mod \
        --enable-slp \
        --enable-overlays=mod \
        --enable-syncprov=yes \
        --enable-ppolicy=yes \
%else
        --disable-slapd \
%endif
        --enable-lmpasswd \
        --with-yielding-select

Looking at the 8th flag down, I see --with-tls specified.

If you need the configuration for a different release of openSuSE, I'm sure you can find a similar line in another source RPM, however, I doubt that the compile flags change very much from release to release.

share|improve this answer

You can download the SRPM and examine the spec file. Being linked against the SSL shared library is a good indication that it is:

$ ldd /usr/sbin/slapd | grep ssl
libssl.so.6 => /lib64/libssl.so.6 (0x00002b1e90a8b000)
share|improve this answer
    
This is an indication that the library is included, but it doesn't necessarily mean that slapd has the code to use it enabled. –  Gene Vincent Apr 8 '11 at 6:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.