Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to install the syntaxhighlightter evolved plugin to my wordpress blog. I've uploaded and activated the plugin, but it did not work. I've looked into the page source code and found out that the plugin style is loaded from the following URL:

http://devermind.com/wp-content/plugins/syntaxhighlighter/syntaxhighlighter/styles/shCore.css?ver=2.0.320

This causes a 404 error (page not found). The strange thing though is that when I remove the GET parameters, the CSS loads ok:

http://devermind.com/wp-content/plugins/syntaxhighlighter/syntaxhighlighter/styles/shCore.css

What could be causing this problem and how can I fix this? Unfortunately I don't know how to make wordpress drop the GET parameters when loading the stylesheet.

EDIT: As I just found out, this happens only in Firefox (3.0.11). IE loads both URLs above just fine. Not that this would be of any help though, so any suggestions would be appreciated.

SECOND EDIT: I tried this on my laptop and it works fine with Firefox 3.08. So this really seems to be a browser problem after all.

share|improve this question
    
devermind.com/wp-content/plugins/syntaxhighlighter/… gives me 200 O... –  rkthkr Jun 15 '09 at 7:36
    
You're right - It works fine, but not in Firefox –  Adrian Grigore Jun 15 '09 at 8:04
    
FWIW, it works fine with Firefox here. –  zarkdav Jun 15 '09 at 8:06
    
Are you using the same Firefox version (3.0.11)? Also, Did you really use the faulty link (the first one above, not the second)? –  Adrian Grigore Jun 15 '09 at 8:31
    
Works with Safari 4, confirmed with curl as well. –  Dave Cheney Jun 15 '09 at 9:35

1 Answer 1

up vote 2 down vote accepted

Works with my Firefox version 3.0.11 and the link with the ver=2.0.320 parameter.

Did you check with your Firefox and disabling all extensions? Just create a new profile, that should disable them all. Check out the Mozilla knowledge base on how to create a new profile.

share|improve this answer
    
Bullseye! It's working fine when using another Firefox profile. Strangely enough, just launching it in safe mode does not help. Now I'll just have to troubleshoot my regular profile. –  Adrian Grigore Jun 15 '09 at 9:08
    
Check your server logs to see what the requested URL is. This may give you a hint at what's going on in the browser. I suspect something is encoding the URL and converting "?" to "%3f". –  Chris Nava Jun 15 '09 at 16:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.