Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've inherited a Windows Server that is used as the backup server for some of our internal machines. One day, seemingly at random, it stopped responding to ping and no longer accepts RDC requests. I can physically log into the box, access it via UNC, and backups are still getting created, but for some reason ping/RDC are hosed.

If it helps, trying to ping it yields the following:

Reply from 10.100.---.---: Destination host unreachable.

Edit: I found this in the event log (related?):

The WinHTTP Web Proxy Auto-Discovery Service service depends on the DHCP Client service which failed to start because of the following error: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

Any suggestions on what might be the problem or where I might start looking?

share|improve this question
    
If you physically log into the box, can it ping the computer you were trying to ping it from? Have you confirmed that the backups being made actually have the expected files in them, and are not just empty backups or old data from unreachable computers? –  DerfK Apr 7 '11 at 17:37
    
Anything in the event log? –  Vick Vega Apr 7 '11 at 17:48
    
Have you tried a reboot? –  joeqwerty Apr 7 '11 at 17:52
    
@derfk - Yes, if the computer in question is ComputerA, I can't ping ComputerA from ComputerB, but I can ping ComputerB from ComputerA (if that makes any sense). For the backups, they're handled by Acronis, so I can't tell what's in the .tib file, but the partial backups have a size corresponding to what I would expect. –  jerhinesmith Apr 7 '11 at 17:53
    
@joeqwerty - I haven't tried a reboot. The machine's only real functionality is as a backup server, and it's still fulfilling that role dutifully, so my fear is that in trying to fix what currently only amounts to an annoyance, I'll end up putting myself in an even worse position. :) –  jerhinesmith Apr 7 '11 at 17:56
show 2 more comments

3 Answers

Do the following:

Open network and sharing and specify the connection type from public or home to domain. Then enable file sharing and confirm the firewall is running. Enabling file sharing automatically adds firewall rules for ICMP commands.

share|improve this answer
    
Why not just turn on the IMCP Echo Request rule instead of opening unnecessary services? –  MDMarra Jun 9 '11 at 19:08
    
Because these will be added by default into firewall rules and there won't be any user issue with doing that. If it works then revert and you know it is a firewall. –  Alex Wilden Jun 10 '11 at 8:55
    
Also if you can browse to the machine via UNC and IP then the issue will be a firewall configuration. Don't just disable the firewall as this will still block traffic. –  Alex Wilden Jun 10 '11 at 8:56
    
IMCPEcho is ping. There's absolutely no point in asking someone to enable more than that to see if the fw is the problem. –  MDMarra Jun 10 '11 at 16:17
    
Like I said Mark, it avoids user error. Quite simple really isn't it. –  Alex Wilden Jun 15 '11 at 7:58
add comment

If it's not the firewall as someone also mentioned have you checked to make sure that it still has a static IP? This would make sense since you can actually access it via UNC.

Also can you access RDP via UNC?

share|improve this answer
add comment

It sounds like someone re-enabled the firewall.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.