Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm working with CentOS 5.5 on a VPS, building a website. All what I want now is just to send mail to users. I decided to do this with postfix and smtp.gmail.com

I had a trouble when setting up Postfix(2.2.3), within the maillog, I found this warning:

warning: SASL authentication failure: No worthy mechs found

So I installed cyrus-sasl(2.1.22), but later I found that maybe libplain and liblogin modules are needed. But, I cannot find libplain.so or liblogin.so under /usr/lib/sasl2 directory.

I wonder how to "add" or "install" these two modules (or plugins)? Or how to reconfigure cyrus-sasl? Or, to be stupid, just remove cyrus-sasl (But this causes another problem: as a dependency of cyrus-sasl, yum remove might also delete postfix..)?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

In CentOS they're under cyrus-sasl-plain:

yum install cyrus-sasl-plain
share|improve this answer
    
Thank you very much, that fixed the problem! –  MessyCS Apr 8 '11 at 4:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.