Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have looked at the settings a great number of times but run into the same issue. When connected to my Linux box with the 'exact' same settings, no fault. When run on a fresh machine with xampp for testing:

SQLSTATE[28000] [1045] Access denied for user 'user'@'localhost' (using password: YES)

I'm positive the user name, privileges and password are the same so anything else I could be missing?

share|improve this question
    
The user is @'localhost' on both computers? –  DerfK Apr 7 '11 at 21:11
    
the user is technically defined as user@% so yes - I also have the same setup running on another windows machine and it works. Just so happens to occur on a fresh laptop install –  JM4 Apr 7 '11 at 21:14
    
@DerfK - note, when I specifically state host as "localhost" in my mysql (I use navicat) configuration, it works, when I use the wildcard % it does not (even though the error above clearly shows it is trying to connect to the localhost hostname –  JM4 Apr 7 '11 at 21:17
    
and this only works on one of the databases, not the other –  JM4 Apr 7 '11 at 21:21
add comment

1 Answer 1

up vote 1 down vote accepted

Probably you have skip-name-resolve option turned on.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.