Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm configuring a Debian Squeeze server to receive syslog from some appliances, but rsyslog is refusing to listen to UDP 514.

The closest I have been able to get from it is to make it listen to TCP 514 with -c2 -r -t514. I haven't found any combination of parameters that got it listening on UDP.

Squeeze's rsyslog version is 4.6.4-2.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

In your /etc/rsyslog.conf:

$ModLoad imudp.so
$UDPServerRun 514

Then in your rsyslogd start options (/etc/sysconfig/rsyslog on RHEL-based distros, not sure where it resides in Debian-based ones), you need to add -r514 to SYSLOGD_OPTIONS.

share|improve this answer
    
The option -r is deprecated on Debian's version. –  Daniel C. Sobral Apr 8 '11 at 2:54
    
And now that you mentioned it, I can clearly see these lines commented close to the top of rsyslog.conf. Shame on me. –  Daniel C. Sobral Apr 8 '11 at 3:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.