Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just upgraded the .NET Framework from 3.5 to 4.0 on Windows 2003 x64. IIS is configured to run in 32 bit mode.

When I run aspnet_regiis -lv I get the Framework64 and Framework of 4.0.30319.0 and the Framework of 2.0.50727.0 listed.

I have a web application with a virtual directory of sems and the Documents -> Enable Default Content Page is set to default.aspx (which is a valid page). If I specify the default.aspx page in the URL it works correctly.

How can I get the default document to work?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

What you have is normally correct. Default docs 'just work'.

The one thing that can turn off default documents is adding a wildcard script mapping. i.e. * for aspnet_isapi.dll. If you do that then you need to write your own default document handler since a / path is handled by .NET instead of IIS 6's default document handler. That's my top guess on what is happening.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.