Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I had installed version 5.3.2 but had to downgrade to 5.2.6 for development purposes.

I uninstalled php 5.3.2,

then rebooted the computer,

then tried installing 5.2.6, an error came up, it said install xml2,

I did, still didn't work, I installed xml2 devel and php installed.

Then I ran a make test that php installation recommended, I forgot to copy the results.

I tried loading a php page and it gave me the option to download the php file instead, because it didn't recognize what a php file was.

I looked at apache modules, it does not contain a php module.

I've tried reinstalling php, that didn't change anything. Any ideas? suggestions? How to get the module to load in apache?

share|improve this question
    
Be more specific. Is this Windows? Linux? Solaris?... By "install" did you mean a package manager or did you compile it yourself?... –  dog Apr 8 '11 at 22:30
    
Oh I'm sorry, I'm using Linux Fedora 14. I am running everything through terminal/ssh/putty. I use yum install for all the stuff. –  Darius Apr 8 '11 at 22:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.