Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running Proftpd on Ubuntu Server 10.04. Filezilla was configured to switch to active mode on failure but connection fails at MLSD time out; Filezilla needs to prefer active mode to connect. Coreftp switched to active from passive and used LIST instead. I don't think I specifically need passive mode but I have a shallow understanding from Google results that passive is encouraged. Although I am behind a NAT for troubleshooting I am using my own network's allocated IPs. Otherwise I have a business line so external IP is static and the cable company's router forwards ports to the server. Is my server misconfigured for passive mode and if so: Is it important to get passive mode working? and how it could be done.

Client logs & proftpd.conf

share|improve this question
    
Why are you using FTP? SCP or SFTP are far better protocols. mywiki.wooledge.org/FtpMustDie –  Tom O'Connor Jan 22 '12 at 22:43
add comment

2 Answers 2

As far as I see, you are connecting to your internal ip (192.168.1.53) but the server gives its external IP (71.127.90.47) according to MasqueradeAddress directive. You are also using TLS, that's why the router may not be able to track the FTP connection.

I had the same problem with my pureftpd server and worked it around with launching two different addresses to announce (like MasqueradeAddress in your case) one for internal zone and one for external (external address is being staticaly NATed be ciso router). These server processes listen to different ports (10021 and 20021). I also added these strings to my iptables config:

-A PREROUTING -i eth0 -p tcp -m tcp --dport 21 -j REDIRECT --to-ports 10021
-A PREROUTING -i eth1 -p tcp -m tcp --dport 21 -j REDIRECT --to-ports 20021

As you see, all requests from internal networ are redirected to "local" server and all others are redirected to "internet" server.

I hope, I understood the problem right and my explanation is clear enough.

P.S. About FTPtest.net. I also tested my server with this tester, but it hav very strict rules. My tests passed with http://www.net2ftp.com/

share|improve this answer
    
I ran into troubles executing your suggestions and I have a feeling I did it wrong. github –  aesthetic priest Apr 15 '11 at 23:11
    
What kind of trouble? Have a look at tcpdump. –  HUB Apr 18 '11 at 9:56
add comment

A simpler answer is to set your ftp client to active mode. Filezilla has it under the 'transfer settings' listed.

May be not very neat, but it worked for me ;)

share|improve this answer
    
This doesn't really answer the question that was posed. Yes it may allow the asker to accomplish the task, but not how to solve the problem so they can use passive. –  Lipongo Nov 3 '12 at 3:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.