Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've asked this before, but it was moved to webmbaster. Really don't know why, becouse it's a Apache/Debian question.

The server is at: www.patagoniatrabaja.com.ar

I've a cake installation at www.patagoniatrabaja.com.ar/cake/ to test the CSS.

Anyway. I'm setting up a server and installed apache. The problem is that it's not serving any Image or relative content. I've changed things in the apche conf. I'll paste it here:

<VirtualHost *:80>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www
    <Directory />
        Options FollowSymLinks
        AllowOverride All
    </Directory>
    <Directory /var/www/>
        Options FollowSymLinks MultiViews
        AllowOverride All
        Order allow,deny
        allow from all
    </Directory>
    <Directory "/var/www/cake">
        AllowOverride All
        Options FollowSymLinks
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
        AllowOverride None
        Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
        Order allow,deny
        Allow from all
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog ${APACHE_LOG_DIR}/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>
share|improve this question
    
It was moved to Webmasters since they also do apache over there, especially .htaccess stuff, which it sounded like it was all about. This includes much more information, thank you. –  sysadmin1138 Apr 11 '11 at 0:27
    
I understand. Thanks. No one answered there though. –  santiago.basulto Apr 11 '11 at 0:33
    
I'm not sure if it matters to the issue you're experiencing but I'm not seeing a closing </html> tag –  mahnsc Apr 11 '11 at 3:09
add comment

2 Answers

Are you getting "Not Found" or "Permission Denied"? Check your error_log for Apache and the HTML source for the served pages. What is the browser being told to ask for? You may need to add one or more alias entries to the config if your static content lives outside of the /var/www/cake path. While I enjoy eating cake, I have yet to use CakePHP. Frameworks often have their own little rules to watch for, so make sure you have configured any "base folder" options or the like.

share|improve this answer
add comment

I was having this problem as well... After shifting around some content (in terms of where it was in the folder structure) and restarting apache I was able to get to serve images & dynamic (php driven) content. I think the problem was the the linking formats which I had used coming from windows.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.