Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to run an AWS EC2 instance for a facebook app. I chose the micro Amazon linux 32-bit as my OS. I'm able to SSH in and install PHP with yum, but when I run phpinfo() I see --without-sqlite in the configuration. Also, my sqlite php page was erroring out on the line that tried to open the sqlite file. I did a yum search for sqlite and php and I didn't see the php5-sqlite pacakge available. How can I get SQLite working with PHP on this system?

share|improve this question

migrated from Apr 11 '11 at 12:42

This question came from our site for professional and enthusiast programmers.

up vote 1 down vote accepted

You can still use PHP PDO to use SQLite3, even if your install of PHP doesn't have native SQLite support compiled in.

You can install the PDO library with:

yum install php-pdo

share|improve this answer
That worked great, thanks! For anyone else that finds this question, I found the PDO tutorial on PHPRO helpful. – James Apr 11 '11 at 16:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.