Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I do incremental backups using dirvish. (dirvish makes incremental backups using rsync and hardlinks).

This has worked perfectly on our old server (nothing fancy, just a linux box with one disk on /). On our new server we have a special mount for mass-storage (SQL dumps and other things). This is an NFS-mount.

The trouble is that the content of the mount is not copied.

I run the copy as root, so I should have all the rights.This is the content as it is on the live-server:

live:/mnt

drwxrwxrwx  5 ouruser      ouruser       4096 2011-03-31 10:14 nfs

live:/mnt/nfs

drwxr-xr-x  9 nobody        nogroup      4096 2011-04-05 13:36 sql-backup

backup:/mnt

drwxrwxrwx  2 anotheruser  anoutheruser  4096 2011-03-31 10:14 nfs

(and that is empty)

It's not clear at all to me why this is. Maybe it's got something to do with rights (the NFS uses a different rights system, right?), but AFAIK I should be able to read (and thus backup) the files. There is a lot of stuff on the internet about dirvish and copying TO NFS, but my target system is just a basic linux box.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I have found the problem, and it is a bit trivial :) From the manual (emph. mine)

Depending on your backup strategy, you may not want Dirvish to cross filesystem boundaries when performing backups. By default, the parameters passed to rsync do not instruct it to remain within a single mount point on the target filesystem. If you want to have a vault for each filesystem being backed up, you will want to enabled the boolean option xdev. If not specified, the default action is to descend into all filesystems that may exist under the specified target.

Now for some reason one of the vaults had a config-file that overrides this default:

xdev: true

Removing that flag should fix my problems.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.