Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

One machine logs cs-uri-queries using + as the space and another in the same farm logs them using %20

I only noticed when searching for a specific document being accessed - one server was giving out 0 hits, which I thought odd, given that the farm is supposed to be load balanced.

I'm guessing its an IIS configuration rather than a logging issue - any ideas where this is set?

share|improve this question
add comment

2 Answers

Grab the Web Deployment Tool and compare the servers.

You can use -verb:sync and -whatif to compare the configurations.

share|improve this answer
add comment

If you have a health check on your load balancer the one without any traffic may be failing the health check. That would explain the traffic differences.

As for the root cause differences, does one have URLScan while the other doesn't? Or it could be other config changes that set them apart. TristanK's suggestion of WebDeploy is a good one to do a diff.

share|improve this answer
    
Both servers are working, its just my search of the logs was only counting foo%20bar.pdf documents and not foo+bar.pdf. I was just wondering why the server is logging differently. –  Adrian Apr 12 '11 at 15:20
    
How are you searching? If you view them in notepad, are they different there too? Are you sure it's not because one visitor uses + and another used %20? If you test yourself and make sure to hit both nodes, do the logs look the same? How about if you visit the nodes directly? Try visiting using both URL formats and see if the logs change or if they remain the same. –  Scott Forsyth - MVP Apr 12 '11 at 18:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.