Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I know I will be told this belongs on Superuser, but I see more related questions here than there, so...

We are running a Windows SBS 2003 Std SP2 server. I am trying to configure a user's Nokia E52 Mail for Exchange profile, but I can't seem to discover the magic combination of correct settings for the mailbox.

Being a default SBS installation, our Outlook Web Access is hosted at http://sbs.oursite.com/exchange/. The connectivity test for ActiveSync (manual server) at https://testexchangeconnectivity.com passed successfully with it set to ignore trust for SSL. (We only have a self-generated SSL certificate). Outlook Web Access works 100% as well.

What do I need to put in Nokia Mail for Exchange for my server name? Is it sbs.oursite.com, or sbs.oursite.com\exchange (like OWA), or sbs.oursite.com\oma for Outlook Mobile Access, or something else? Does the server name need an http or https prefix?

I've tried practically all combinations I can think of without success. Worst of all, I do not receive any error messages. All I have is an empty mailbox on the phone, which shows an icon as if it is connected - but connected whatever settings I put in for the server!

Has anyone got this working before? Why is it so tricky? Another user has a Blackberry: all that you need to do is tell it your OWA address, username and password; and it just works.

Thanks in advance

share|improve this question
    
One more thing - I have converted and installed our SBS cert onto the Nokia handset –  Nicolas Apr 12 '11 at 10:57
    
I found a thread with screenshots and they talk about importing the certificate to the phone here: blog.brightpointuk.co.uk/setting-mail-exchange-nokia-e52 –  charnley Apr 12 '11 at 12:48

2 Answers 2

up vote 2 down vote accepted

Believe it or not, the problem was simply that Mail for Exchange did not like the access point I configured for it. I changed it to use the "WAP Services" destination which was predefined on my handset. I tried recreating a new destination containing only a packet data access point, and straight away it failed again.

Pointers:

1) In the root of the phone memory, there is a folder called "MailForExchange". Here you will find log files that tell you what is actually happening, otherwise you are flying blind.

2) You need to convert you SBS cert from a .cer file to a .der file and install it on the handset. There are online services to do this for you.

3) The server name that you need to use is simply the URL that resolves to your server, no extra paths or anything are required. e.g. sbs.oursite.com is correct for Mail for Exchange, if you use http://sbs.oursite.com/exchange/ for Outlook Web Access.

4) Ports 80 & 443 need to be forwarded on your router to your server's internal IP address. This is already done if you are using Outlook Web Access.

share|improve this answer

I realize this may be old, but it is entirely possible that the reason is that the phone account is not a business account, and is prevented from accessing OWA. I recently moved a client from POP3 to hosted Exchange, and we had to upgrade the plans.

I will not be phone-specific since I do not know about Nokia off the top of my head, but in general, any one of the following may work: sbs.oursite.com, sbs.oursite.com\exchange (or \OWA depending on the version of Exchange), https://sbs.oursite.com, https://sbs.oursite.com\exchange, or even sbs.oursite.com:443\exchange (this is for the iPhone). Or one last possibility, just sbs.oursite.com, or sbs.oursite.com\exchange and you have to check a box use SSL (this is for the Droid).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.