Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I attempted to move my database to a different mount on my Ubuntu installation on an amazon EC2 instance, because it was filling up the root directory. I think I've borked something up. When I run:

$ sudo mysqld --datadir=/var/lib/mysql --user mysql
110412 11:36:44 [Warning] Can't create test file /mnt/var/lib/mysql/ip-10-244-207-161.lower-test
110412 11:36:44 [Warning] Can't create test file /mnt/var/lib/mysql/ip-10-244-207-161.lower-test

In /var/log/mysql/error.log:

110412 16:01:27 [Note] Plugin 'FEDERATED' is disabled.
/usr/sbin/mysqld: Can't find file: './mysql/plugin.frm' (errno: 13)
110412 16:01:27 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
/usr/sbin/mysqld: Can't create/write to file '/mnt/tmp/ibRTnZix' (Errcode: 13)
110412 16:01:27  InnoDB: Error: unable to create temporary file; errno: 13
110412 16:01:27 [ERROR] Plugin 'InnoDB' init function returned error.
110412 16:01:27 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
110412 16:01:27 [ERROR] /usr/sbin/mysqld: Can't create/write to file '/mnt/var/lib/mysql/ip-10-244-207-161.pid' (Errcode: 13)
110412 16:01:27 [ERROR] Can't start server: can't create PID file: Permission denied

The file ip-10-244-207-161.lower-test does not already exist:

ls -l /mnt/var/lib/mysql
total 20532
-rwxr-xr-x 1 mysql root         0 2011-02-28 22:23 debian-5.1.flag
-rwxr-xr-x 1 mysql mysql 10485760 2011-04-12 07:31 ibdata1
-rwxr-xr-x 1 mysql mysql  5242880 2011-04-12 07:31 ib_logfile0
-rwxr-xr-x 1 mysql mysql  5242880 2011-02-28 22:23 ib_logfile1
drwxr-xr-x 2 mysql root      4096 2011-02-28 22:23 mysql
-rwxr-xr-x 1 mysql root         6 2011-02-28 22:23 mysql_upgrade_info
drwxr-xr-x 2 mysql mysql     4096 2011-04-11 08:22 scrapy_cache

The directories seem to be accessable:

$ ls -l /mnt/var/lib/ | grep mysql
drwxr-xr-x 4 mysql mysql 4096 2011-04-12 07:31 mysql

$ ls -l /var/lib/ | grep mysql
lrwxrwxrwx 1 mysql     root      18 2011-04-12 09:05 mysql -> /mnt/var/lib/mysql

ls -ld /mnt/{,var/{,lib/{,mysql}}}
drwxr-xr-x 5 root  root   4096 2011-04-12 07:27 /mnt/
drwxr-xr-x 3 mysql root   4096 2011-04-12 07:29 /mnt/var/
drwxr-xr-x 3 mysql ubuntu 4096 2011-04-12 07:33 /mnt/var/lib/
drwxr-xr-x 4 mysql mysql  4096 2011-04-12 07:31 /mnt/var/lib/mysql

The parts I changed in my.cnf:

user            = mysql
socket          = /var/run/mysqld/mysqld.sock
port            = 3306
basedir         = /usr
datadir         = /mnt/var/lib/mysql
tmpdir          = /mnt/tmp
skip-external-locking

I would really appreciate some help on this as I've failed miserable while trying to debug it.

I did a sudo chown -R mysql /mnt/var/lib/mysql so everything should be owned by the mysql server. /mnt is most certainly writable as I ran mv /var/lib/mysql /mnt/var/lib/ when I migrated. Mount confirms this:

$ mount | grep /mnt
/dev/sda2 on /mnt type ext3 (rw)

The disk is not full in space and it hasn't run out of inodes, disk quota don't seem to be active I installed repquota but it outputted absolutely nothing:

$ df -h /dev/sda2
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda2             335G  2.0G  316G   1% /mnt

$ df -i /dev/sda2
Filesystem            Inodes   IUsed   IFree IUse% Mounted on
/dev/sda2            44564480     104 44564376    1% /mnt

Creating things as the MySQL user works, as suggested in the comments:

$ su -s /bin/bash - mysql

$ touch /mnt/var/lib/mysql/ip-10-244-207-161.lower-test

$ ls -ld /mnt/var/lib/mysql/ip-10-244-207-161.lower-test
-rw-r--r-- 1 mysql mysql 0 2011-04-12 14:10 /mnt/var/lib/mysql/ip-10-244-207-161.lower-test

$ rm -f /mnt/var/lib/mysql/ip-10-244-207-161.lower-test
$ ls -ld /mnt/var/lib/mysql/ip-10-244-207-161.lower-test
ls: cannot access /mnt/var/lib/mysql/ip-10-244-207-161.lower-test: No such file or directory

MySql isn't running.

$ ps aux | grep mysql
ubuntu   20825  0.0  0.0   3700   776 pts/1    S+   15:40   0:00 grep --color=auto mysql

/etc/mysql/my.cnf

#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
# 
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port        = 3306
socket      = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket      = /var/run/mysqld/mysqld.sock
nice        = 0

[mysqld]
#
# * Basic Settings
#

#
# * IMPORTANT
#   If you make changes to these settings and your system uses apparmor, you may
#   also need to also adjust /etc/apparmor.d/usr.sbin.mysqld.
#

user        = mysql
socket      = /var/run/mysqld/mysqld.sock
port        = 3306
basedir     = /usr
datadir     = /mnt/var/lib/mysql
tmpdir      = /mnt/tmp
skip-external-locking
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address        = 127.0.0.1
#
# * Fine Tuning
#
key_buffer      = 16M
max_allowed_packet  = 16M
thread_stack        = 192K
thread_cache_size       = 8
# This replaces the startup script and checks MyISAM tables if needed
# the first time they are touched
myisam-recover         = BACKUP
#max_connections        = 100
#table_cache            = 64
#thread_concurrency     = 10
#
# * Query Cache Configuration
#
query_cache_limit   = 1M
query_cache_size        = 16M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
# As of 5.1 you can enable the log at runtime!
#general_log_file        = /var/log/mysql/mysql.log
#general_log             = 1

log_error                = /var/log/mysql/error.log

# Here you can see queries with especially long duration
#log_slow_queries   = /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication slave, see README.Debian about
#       other settings you may need to change.
#server-id      = 1
#log_bin            = /var/log/mysql/mysql-bin.log
expire_logs_days    = 10
max_binlog_size         = 100M
#binlog_do_db       = include_database_name
#binlog_ignore_db   = include_database_name
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names
max_allowed_packet  = 16M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition

[isamchk]
key_buffer      = 16M

#
# * IMPORTANT: Additional settings that can override those from this file!
#   The files must end with '.cnf', otherwise they'll be ignored.
#
!includedir /etc/mysql/conf.d/
share|improve this question
2  
Let's test! su -s /bin/bash - mysql, then touch /mnt/var/lib/mysql/ip-10-244-207-161.lower-test. Does it succeed? Next, still as "mysql", ls -ld /mnt/var/lib/mysql/ip-10-244-207-161.lower-test. Does that work? Lastly, as mysql, rm -f /mnt/var/lib/mysql/ip-10-244-207-161.lower-test, followed by an ls: is it really gone? –  BMDan Apr 12 '11 at 12:42
1  
@BMDan - Good suggestions, it all passes. This issue is becoming increasingly confusing to me. Gha. –  Kit Sunde Apr 12 '11 at 14:13
    
Can you post the output of ps aux | grep mysql and the contents of the configuration files (/etc/my.cnf or /etc/mysql/my.cnf)? –  Lekensteyn Apr 12 '11 at 15:36
    
@Lensteyn - Here you go. MySql isn't running (this was the first thing I checked). I've posted the full config file. –  Kit Sunde Apr 12 '11 at 15:47

5 Answers 5

Does the file /mnt/var/lib/mysql/ip-10-244-207-161.lower-test exist? If yes, is it owned by mysql? All files an directories in /mnt/var/lib/mysql should be owned by the MySQL user.

Is /mnt mounted as rw (read-write), and not ro (read-only)? You can check that by running mount (without arguments).

MySQL has a page in their documentation on this error. It basically means that the data directory or filesystem is write-protected.

Are disk quota's active? You can check the current quota status (if installed) with:

sudo repquote -a

Is the disk full? Check the current disk usage with:

df -h
share|improve this answer
    
The file does not exist no. I did a sudo chown -R mysql /mnt/var/lib/mysql so they are. /mnt must be rw because I ran mv /var/lib/mysql /mnt/var/lib/ when I migrated (checking mount confirms tihs). –  Kit Sunde Apr 12 '11 at 12:01
    
@Kit: updated my answer. Can you post the relevant part of the output of mount and df -h? –  Lekensteyn Apr 12 '11 at 12:09
    
Thanks for updating, I've updated the post with mount and df -h as you suggested. Everything seems to be in order :( –  Kit Sunde Apr 12 '11 at 14:13

It smells like the problem might be due to insufficient permissions on the parent-directories of /mnt/var/lib/mysql, and probably /mnt/var in particular. Can you post the output of ls -ld /mnt/{,var/{,lib/{,mysql}}}?

EDIT: Ok, thought about this some more. You say you changed the location of the socket in my.cnf - could it be that the server is successfully starting (check with ps ax | grep mysql) but the mysql client you're using is looking for the socket somewhere else e.g. an old location? What's the full error message you get from running mysql ?

share|improve this answer
    
Added to the question. –  Kit Sunde Apr 12 '11 at 11:58
    
No the MySQL server isn't starting. I stupidly realized that there should be an error log somewhere since mysql was only echoing [Warnings]. Editing in the error log. –  Kit Sunde Apr 12 '11 at 16:03
up vote 3 down vote accepted

I finally figured out what the problem was. I had on the instance running (installed by default). To make its stop complaining I did:

sudo aa-complain /usr/sbin/mysqld

Now starts like expected and I can query my data. I feel bad for taking up so much time for such a trivial issue and I really appreciate how helpful everyone has been. I wouldn't have figured out the problems with without user78151 asking about .

An alternative solution can be to configure to allow you to use those directories (I don't care either way) which was described in a blog post I found.

share|improve this answer
1  
If this answer solves your problem, mark it as accepted. I was about to post the same after I've read the line before the configuration about apparmor. Lesson for the next time: do not ignore comments :) –  Lekensteyn Apr 13 '11 at 7:52
    
I would've but I can't for 2 days after answering. –  Kit Sunde Apr 13 '11 at 8:28
    
Glad you figured it out. In unrelated news, based on the log, you should really run mysql_upgrade. :) –  BMDan Apr 14 '11 at 11:29

Check SELinux. If SELinux is on, you will need to re-label or turn it off. This would give a permissions error message.

share|improve this answer
    
sestatus says disabled. –  Kit Sunde Apr 12 '11 at 15:40

Did you mistype the data directory?

You wrote:

$ sudo mysqld --datadir=/var/lib/mysql --user mysql

but should be:

$ sudo mysqld --datadir=/mnt/var/lib/mysql --user mysql
share|improve this answer
    
I'm afraid not, /var/lib/mysql is a symbolic link to /mnt/var/lib/mysql. It made no difference when I tried running that instead. –  Kit Sunde Apr 12 '11 at 14:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.