Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Ubuntu 10.10 x86_64 2.6.35-28 installed on two mirror machines. Kernel processes are slowly consuming whole available memory over time. Tooks around 10 days to eat up 4GB which leads to obvious total crash.

On the pastie below, you can check how does the slab info looks like around 24 hours prior to coming crash.

Its always kmalloc-192 and kmalloc-32 which are leaking the memory with the mutual proportion 6:1 (192:32). I am not really sure where to go from that point. Is there any other possible way to diagnose to cause a bit deeper?

I found out some posts from people with quite similiar issue on pretty much same hardware. The proposed solution was to disable acpi and apm, but it doesn't solved the issue on my boxes.

Any ideas much appreciated.

Hardware is from HP (DL360G5).

The most odd thing is, that slub_debug fixes the problem. There is no leak with debug enabled. I tried few times back and forth. Looks like the corelation is consistent!

share|improve this question
Are you doing any virtualisation? I had this issue once but it was unreproducable, and I suspected it was a virtualisation issue. – Robin Green Apr 12 '11 at 14:01
No virtualization at all on this box. First I though it was related to but looks like its not a DRM issue. Now it looks like noapic fixed the issue. Box is running with noapic and slub_debug for couple of hours now, and there is no leak whatsoever. I am going to verify that sometime tommorow, by juggling this option back and forth. Issue is clearly detectable after like 5 mins already – mdrozdziel Apr 12 '11 at 16:48 link to the bug report. – mdrozdziel Jul 20 '11 at 5:14
up vote 1 down vote accepted

Upgrade to resolved the issue.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.