Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am not sure what is going on, but recently all the Office documents on our intranet get prompted a second time for login and according to the error logs it looks like it's trying to use webdav to open (an editable?) version of the document to save directly on the server? We have no sharepoint server setup or anything, but this shouldn't be happening. All I want is for the document to be saved or opened from a local copy in temp like normal.

Here is the log:

Line 57499: 2011-04-12 15:57:10 (ip) OPTIONS (address) - 443 (username) (user ip) Microsoft-WebDAV-MiniRedir/6.1.7601 - 401 1 1326 1525 238 0
Line 57500: 2011-04-12 15:57:10 (ip) OPTIONS (address) - 443 (username) (user ip) Microsoft-WebDAV-MiniRedir/6.1.7601 - 401 1 1326 1525 238 0
Line 57501: 2011-04-12 15:57:10 (ip) OPTIONS (address) - 443 (username) (user ip) Microsoft-WebDAV-MiniRedir/6.1.7601 - 401 1 1326 1525 238 0

The log basically contains a bunch of these.

How can I disable this behavior so that office documents that are downloaded aren't attempted to be used through webdav??

Edit: I should clarify behavior, it asks if you want to save or open it, upon choosing open open, it asks to re-authenicate, you put in the user information and the login box comes up 3 times acting like you entered the wrong password. For some users, after passing the login box the third time, it still opens up, for others their browser just locks up.

It also doesn't even look like webdav is installed on our server, I see no config options in IIS for it as outlined on this page: http://learn.iis.net/page.aspx/350/installing-and-configuring-webdav-on-iis-7/#001

share|improve this question
    
Is this happening on all servers or just one in particular? –  Dave Wise Apr 12 '11 at 16:38
    
@David Wise we only have 1 web server. The page that contains the links, the documents to be downloaded, the auth, it all resides on one server using iis 7 and server 2k8 r2. –  DOTang Apr 12 '11 at 16:39
    
When you browse to the the site containing the documents, does it say "Internet", "Intranet" or "Trusted Site" in the bottom right of the IE status bar? –  Dave Wise Apr 12 '11 at 17:00
    
@David Wise it says Internet | Protected Mode on, we using basic auth and NTFS permissions for our intranet. I may be mis-using the term intranet, but it's just a password protected site on the web via basic auth. –  DOTang Apr 12 '11 at 17:14
add comment

1 Answer

up vote 1 down vote accepted

Open IE and browse to the server you are having troubles with then go to tools - Internet Options - Security - Local Intranet and click on "Sites" then click on "Advanced" and add the url to the "websites" box. Since this is an intranet server anyway, it really should be listed in the Intranet zone in IE.

You should no longer be prompted to login in either IE or in Office when opening the documents from that server.

My bet is that something happened on the clients (either a patch or a change to corporate policies) that pushed the URL back to your Internet zone, which requires a login.

share|improve this answer
    
Hi Dave, appreciate your response, but this didn't fix it, the error still occurs. Also, the problem with your solution is that I don't want user to be able to edit the document on the server just by opening a link to it. I want it to act like a normal download, it shouldn't be trying to open it for editing directly on the server, but I don't know how to disable this. –  DOTang Apr 12 '11 at 17:30
    
Well, one thing to try then is to simply block the verbs "OPTIONS" and "PROPFIND" from your site. This can be done directly in IIS or in the web.config for the site. –  Dave Wise Apr 12 '11 at 17:37
    
what would the code be for that? Having some difficulty finding examples. Would this interfere with network shares that users access through mapped drives though? I just searched my logs and see instances of OPTIONS firing when people open office files from their mapped share. Also from what I'm reading, woudln't that just outright prevent those files on the site from being accessed? Seems like it would just return a 404.6 instead of a 401.1 then. –  DOTang Apr 12 '11 at 17:52
    
Nevermind, it worked! –  DOTang Apr 12 '11 at 18:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.