Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've installed SSH Secure Shell and xming on my laptop running Windows 7 (64-bit). I'm having trouble starting X Windows applications from the SSH console. I've been able to do it in the past. I've pretty much determined that it's not a server issue because I've tried it on two different servers (both servers are running RHEL 5).

Running "echo $DISPLAY" on either server gave me "localhost:10.0".

My XLaunch configuration settings are: Multiple Windows, 10 (display number), and Start no client. Once xming has launched, I'll try to execute something like "firefox" and I get this back:

The application 'firefox' lost its connection to the display localhost:10.0; most likely the X server was shut down or you killed/destroyed the application.

I've already checked to make sure that the X server is running and it is:

root 12579 2689 0 Feb14 tty7 00:04:23 /usr/bin/Xorg :0 -br -audit 0 -auth /var/gdm/:0.Xauth -nolisten tcp vt7

Additionally, X11 Tunneling has been enabled in SSH as well as SSH 2 connections.

share|improve this question

2 Answers 2

Check if ssh server is configured to allow X11Forwarding and that the ssh client has created the tunnel. The X server running on remote machine (I mean /usr/bin/Xorg) is not used when you need to display the X application on your desktop - you can even stop it.

What ssh client are you using? Can you add to your question the detailed log of the SSH client?

share|improve this answer
    
X11 Forwarding is set to yes in the /etc/ssh/sshd_config file on the server. The client is SSH Secure Shell. I don't really have any other output from the SSH client other than the error message I mentioned. –  Brian Apr 12 '11 at 19:08
    
Which company made that software? Can you try also with PuTTY? Do you see the sshd listening on –  Mircea Vutcovici Apr 12 '11 at 19:17
    
Can you post the output of sudo netstat -tlnp|grep :601[0-9] on the remote host? –  Mircea Vutcovici Apr 12 '11 at 19:18
1  
Well, I got it working...finally. The only difference was that I didn't specify a display number for xming and just went with the default of 0. Not really sure why that worked, but it does. –  Brian Apr 12 '11 at 19:19

The solution from the comments

Well, I got it working...finally. The only difference was that I didn't specify a display number for xming and just went with the default of 0. Not really sure why that worked, but it does.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.