Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm on a openvz vps and I have memory thats unaccounted for. When I run free -m it says I have 156mb used out of a vps with 256mb. Cached is 0, buffers are 0, shared is 0. But when I run "ps -faux" the memory usage is nowhere near 156mb and the total comes more to 50mb'ish.

Ive also run rootkit hunter and chkrootkit and nothing's shown up.

Anyone know whats going on and how to find out whats using the memory?

edit: ive doubled checked memory usage using a program I found vzfree which uses beancounters and is supposedly more accurate but I got the same memory usage.

edit2: If your running openvz they have different memory accounting. I found the solution here.stack size

share|improve this question
    
Glad you found the cause. –  Jonathan Ross Apr 13 '11 at 6:39
    
+1 Thanks for providing the solution –  Aleksandr Levchuk Apr 13 '11 at 13:41
    
In addition, in multiple threads, top will over count memory that's shared between threads. For accurate, top-like view of the memory usage per-thread check out my github.com/alevchuk/memtop –  Aleksandr Levchuk Apr 13 '11 at 13:49

1 Answer 1

This handy tool might help decipher /proc/user_beancounters better:

vzfree

--edit--

Are you sure this isn't the reason ? I notice a massive difference between a minimal Ubuntu build and a Debian build ... Debian doesn't grab all the memory: Linux ate my RAM !

share|improve this answer
    
yeah I just read that somewhere but the numbers come out the same. –  Incognito Apr 13 '11 at 6:00
    
+1 nice vz script –  Aleksandr Levchuk Apr 13 '11 at 13:33
    
Wish I'd written it :-) Glad it helped. –  Jonathan Ross Apr 13 '11 at 13:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.