Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

One of my disks failed in my raid array:

cat /proc/mdstat:

Personalities : [raid1] 
md1 : active raid1 sda2[2](F) sdb2[1]
      488086720 blocks [2/1] [_U]

md0 : active raid1 sda1[0] sdb1[1]
      192640 blocks [2/2] [UU]

When i tried to remove then re-add the drive the following happened:

mdadm: hot removed /dev/sda2
host:# mdadm /dev/md1 --add /dev/sda2
mdadm: add new device failed for /dev/sda2 as 2: Invalid argument

fdisk -l /dev/sda returns nothing.

Can you tell me what's happening now, especially because md0 looks fine. Tried to Google it but nothing interesting come up.

Update (just for verbatim), now md0is failed too:

Personalities : [raid1]
md1 : active raid1 sdb2[1]
     488086720 blocks [2/1] [_U]

md0 : active raid1 sda1[2](F) sdb1[1]
     192640 blocks [2/1] [_U]
share|improve this question
    
Does dmesg or /var/log/kern.log shed any light on this with regards to drive errors? –  DerfK Apr 13 '11 at 13:15
2  
@DerfK: Thank you. Looks like it's totally dead? end_request: I/O error, dev sda, sector 976559000, md: disabled device sda2, could not read superblock. –  fabrik Apr 13 '11 at 13:24
    
@upvoter: now is the time when i'm not too happy because of a +1 :( –  fabrik Apr 13 '11 at 14:21

2 Answers 2

up vote 1 down vote accepted

Sounds like the sda drive is dead. I'm guessing md0 was for booting, which means it probably didn't get accessed much so its driver doesn't know sda1 is dead too.

Before you reboot the computer, make sure that you've installed grub to sdb since the BIOS probably isn't going to be able to boot off of that first drive.

If you didn't already do this, you'll need to run grub, then on grub's command prompt do:

root (hd1,0)
setup (hd1)

(From the guide here for grub 0.95, I'm not sure if this has changed in newer versions of grub) (Note: hd1 assumes that sdb is the second drive in the system, if you've mixed IDE (hda) and SATA/SCSI drives, then you might have to figure this one out on your own)

share|improve this answer
    
thank you for your detailed answer. I'm in really trouble now because the cube is about 200kms from me. Now i must to build a secondary server in a blazing fast speed and dump everything onto it. Thank you, again. –  fabrik Apr 14 '11 at 6:22

You need to replace sda. It's pooched.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.