Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Domain Name: digiwhirl.com

Edition: Free edition

Affected Username/s: N/A

Issue Description: Cannot recieve incoming email on recently transferred domain - all MX records updated and have proper status

Steps to Reproduce (if applicable): Email bounces back if sent to any user on this domain. However, these users can send outgoing email to any other domain.

I changed the MX records for my domain for Google Apps about 30 hours ago.

    0 digiwhirl.com

1 aspmx.l.google.com

    5 alt1.aspmx.l.google.com

    5 alt2.aspmx.l.google.com

    10 aspmx2.googlemail.com

    10 aspmx3.googlemail.com

However, I am not able to get any incoming mail for domain.

I am able to send new email (outgoing).

I checked the status of my MX Records from a couple of lookup websites (Websitestuff & DNSStuff), and they say things are fine. Updates: On sending any email, the mailer-daemon responds back instantly with the following error:

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 550 550-mail-ey0-f177.google.com [209.85.215.177] is currently not permitted to
550 relay through this server. (state 14).

----- Original message -----

MIME-Version: 1.0
Received: by 10.14.11.199 with SMTP id 47mr3192398eex.87.1302707326011; Wed,
13 Apr 2011 08:08:46 -0700 (PDT)
Received: by 10.14.48.67 with HTTP; Wed, 13 Apr 2011 08:08:45 -0700 (PDT)
X-Originating-IP: [120.63.31.108]
Date: Wed, 13 Apr 2011 20:38:45 +0530
Message-ID: <BANLkTinc0r8ZYGF-gO6VvG0w63C99P+6GQ@mail.gmail.com>
Subject: asd
From: *obfuscated*<*obfuscated*@gmail.com>
To: *obfuscated*<*obfuscated*@digiwhirl.com>
Content-Type: multipart/alternative; boundary=0016364c7cc369c94e04a0ce2f1e 4/13/11

Any help ?

share|improve this question

5 Answers 5

up vote 2 down vote accepted

Google's mail server is rejecting the message because, it would appear, that Google doesn't know they're supposed to be the authoritative recipient of those messages. The "clue" is the mention of relaying in the error message. That means that the recipient server is "seeing" the message as a relay attempt, not a local delivery attempt.

Are you certain that Google's service is configured for the correct domain name and all paid-up, provisioned, etc?

share|improve this answer
    
Yes, I've been poring over Google Apps settings for hours. All seems to be fine on their end. –  Hrishikesh Choudhari Apr 13 '11 at 16:24
    
@Hrishikesh Choudhari: I think you may have to attempt to get some support from Google. (Good luck getting a human, too... I've heard it's notoriously difficult to get human support from Google.) The rejection you're seeing is definitely coming from their server and is definitely because their server doesn't think it should be accepting the incoming messages. –  Evan Anderson Apr 13 '11 at 16:29
    
@Evan: I've posted it on the Google Apps forum - google.com/support/forum/p/Google+Apps/… - If not this, and not SF, then it surely seems as a dead end. –  Hrishikesh Choudhari Apr 13 '11 at 16:32
    
@Evan: BTW, how do I even start to get human support from Google ? –  Hrishikesh Choudhari Apr 13 '11 at 16:32
    
@Hrishikesh Choudhari: I've only ever been able to get human help from Google thru a salesperson and, then, only a larger account (300+ users). –  Evan Anderson Apr 13 '11 at 22:07

I'm a Google Apps Certified Reseller. Contact me directly and I'll help you through this. Only condition: For the benefit of the community, we will publish the solution once solved.

share|improve this answer

While not the answer for Hrishikesh, I wanted to share another possibility for future visitors to this question.

I was encountering a similar problem after migrating DNS management to a BlueHost account. It turns out there's a setting for the MX records "Email Routing" that you have to set the routing to "Remote Mail Exchanger" in order for the Google Apps email servers to accept the email.

Here's the URL for a screenshot of the correct setting that fixed it for me. (I don't have enough rep to post an image yet.) BlueHost Email Routing Screen Shot

share|improve this answer

Most likely because you have 0 digiwhirl.com in your MX records and possibly have emails accounts on the same server swallowing the emails.

share|improve this answer
    
Thanks @steve.. You're right, I removed that particular MX record and things were rosy again. –  Hrishikesh Choudhari Jun 7 '12 at 21:44

Avoid bounced messages after changing MX records

http://www.google.com/support/a/bin/answer.py?answer=45679

"Any time you change your MX records, it can take up to 48 hours for your new records to propagate."

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.