Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have VMware server installed on Ubuntu Server 10.04. I managed to get to the VMware Infrastructure Web Access interface, however I didn't allocate enough space on my LVM initially to start adding virtual machines.

I just resized using lvresize to 360GB, as shown using lvdisplay (Size 357.80 GiB). But the standard datastore in the VMware Infrastructure Web Access interface still says it has a 17.52 GB capacity.

Is resizing the LVM enough or do I have to resize something else to get this to work? Or is it simply that VMware hasn't updated for some reason? I already tried restarting the vmware services and that didn't work... anyone have any suggestions?

share|improve this question
    
Have you tried restarting vmware services? Rebooted the machine? –  Vick Vega Apr 13 '11 at 21:08
    
Trying a machine reboot right now... no dice. –  user29600 Apr 13 '11 at 21:13
    
When logging in after rebooting it says "Usage of /: 14.3% of 17.52GB"... looks like that's where my problem is, it didn't actually resize the partition. I did the lvresize on /dev/hostname/root and the lvdisplay on /dev/hostname/root and it says 357.80 GiB... –  user29600 Apr 13 '11 at 21:21

1 Answer 1

up vote 1 down vote accepted

Your lvm has been extended, but the filesystem on top of it is still the size of the old disk.

Unmount the partition (probably shutting down the VMware services beforehand):

/etc/init.d/vmware stop
umount /dev/mapper/volumename

Then extend the filesystem; the command to do the extend depends on which filesystem is running.

For ext4, the default on Ubuntu 10.04:

resize4fs /dev/mapper/volumename

Or, for ext2/3:

resize2fs /dev/mapper/volumename
share|improve this answer
    
Thanks! It is ext4. Does it matter if it's root I'd need to unmount? –  user29600 Apr 14 '11 at 14:42
    
@user29600 Yup, that won't work. In that case, you'll want to boot to something else to make the needed change. I'll recommend System Rescue CD. –  Shane Madden Apr 14 '11 at 14:59
    
Uh... I'm looking in gparted using System Rescue CD and it says my /dev/Hostname/root isn't in there are a partition. It only lists /dev/sda1, /dev/sda2 > /dev/sda5, and unallocated. –  user29600 Apr 14 '11 at 15:45
    
@user29600 Gparted doesn't support LVM; you'll want to just use the normal ol' command prompt. –  Shane Madden Apr 14 '11 at 15:59
    
Sorry to continue this for so long, I appreciate the help. I'm out of gparted. root@sysresccd /root % fdisk -l, still lists the same as above. lvdisplay and vgdisplay say "No volume groups found". ideas? –  user29600 Apr 14 '11 at 16:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.