Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We are experiencing the same issues as described in this post on TechNet. We use Remote Desktop to log into Windows XP machines remotely. If the connection is lost the user is logged out instead of being disconnected. I checked in GPO for the remote desktop settings but they are all set to no session limit. It doesn't matter for how long the connect is lost, the log off happens immediately.

This happens when using both Windows 7 and Windows XP. Are there any other policies I should check? I see this question asked a lot online but I don't see a solution.

Our servers are Windows Server 2003, clients are Windows XP.

Update: I tested using remote desktop into a Windows 7 computer and the user remains logged in. So this is isolated to Windows XP it seems.

share|improve this question
    
Anything in the event log? –  Nixphoe Apr 24 '11 at 23:34
    
Only in the Security log where it says "User Logoff". Application and System don't show any messages about it. –  Andy May Apr 26 '11 at 18:59
    
Have you looked into what is causing the connections to be lost? Maybe someone is logging into the Win XP machines locally (or remotely) forcing the connection closed and logging that user off? –  Nixphoe Apr 26 '11 at 19:11
    
Also is the computer getting the GPO applied correctly? Should be able to check that with the command gpresult. Is fast user switching turned on? What service pack are the XP machines on? –  Nixphoe Apr 26 '11 at 19:15
    
Yes, the GPO is applied. The reason for disconnect isn't caused by anything local, I can reproduce the disconnect instead of log off issue by turning off the wireless on my laptop while connected remotely. XP SP3. The machines are on a domain so fast user switching is not available. –  Andy May Apr 26 '11 at 19:36

1 Answer 1

The Terminal Services server component on a Windows XP uses configuration settings stored in the registry.

Registry key: HKLM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp\
Registry value: MaxDisconnectionTime

If MaxDisconnectionTime has a very low value, this may be causing the issue. Try setting this to 0 (no timeout).

Note:

  • This setting is in milliseconds. A value of 60000 (decimal) = one minute.
  • The setting does not take affect for the current session. I would restart to be sure, but it should take affect when you log off and log back on.
  • There may be some other settings under that registry key that affect the behavior. You may want to also set MaxIdleTime and MaxConnectionTime to 0.
share|improve this answer
1  
Unfortunately this was already set to 0 for the value. –  Andy May Apr 26 '11 at 18:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.