Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Ubuntu server running a LAMP stack, and set up the permissions on /var/www such that all developers in our organisation are members of the www-data group, and the directory permissions are 2775 (rwxrwsr-x), file permissions should all be 664 - I've also set the default umask in /etc/profile to be 0002.

This all works great, except that any file created by PHP on the server only has permissions 644 (rw-r--r--)...

I'm trying to find something in PHP or Apache configuration (probably PHP) that sets new files to be 664 by default - is there such a beast?


I found the following information at

Adding the line:

umask 0002

to /etc/apache2/envvars and restarting the server should work.

I restarted, without error, but it doesn't seem to have changed a thing. My PHP-generated files are still not group writeable.

share|improve this question
up vote 1 down vote accepted

Have you tried using PHP's umask() function? It's very possible that PHP enforces a set of file permissions of its own...

share|improve this answer
Thanks - interesting to see that, but I was hoping for a configuration option... – HorusKol Apr 14 '11 at 5:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.