Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Am trying to upload my vexim database but this is the error i get. Anyone with an idea how to solve this? I have tried it with two versions of vexim that is vexim2.2.1.and vexim 2 but i got the same error in both. As below:

mysql -u root -p vexim < setup/mysql.sql
Enter password: 
ERROR 1064 (42000) at line 1: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-
-
-
CREATE DATABASE IF NOT EXISTS `vexim`' at line 1**
share|improve this question

1 Answer 1

You have something in your setup/mysql.sql file that is not clean SQL code. Maybe a stray quote or something?

share|improve this answer
    
thank you. Though wat i changed in setup/mysql.sql file is only the UID and GID. –  Sspec Apr 14 '11 at 7:45
    
You must have made some other subtle change that broke the formatting. –  Caleb Apr 14 '11 at 7:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.