Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have /etc/auto.master:

/cpy/users  /etc/auto.users --timeout=90

I have /etc/auto.users:

*   -fstype=nfs4,rw,proto=tcp,port=2049   server:/users/&

On an "ordinary" CentOS 5 machine, these work splendidly. On my virtual machine which has been built using "yum groupinstall core" and some minor adjustments, I get this when user myself logs in:

Apr 14 09:33:29 testing automount[5240]: handle_packet: type = 3
Apr 14 09:33:29 testing automount[5240]: handle_packet_missing_indirect: token 136, name myself, request pid 5249
Apr 14 09:33:29 testing automount[5240]: attempting to mount entry /cpy/users/myself
Apr 14 09:33:29 testing automount[5240]: lookup_mount: lookup(program): looking up myself
Apr 14 09:33:29 testing automount[5240]: lookup(program): lookup for myself failed
Apr 14 09:33:29 testing automount[5240]: ioctl_send_fail: token = 136
Apr 14 09:33:29 testing automount[5240]: handle_packet: type = 3
Apr 14 09:33:29 testing automount[5240]: handle_packet_missing_indirect: token 137, name myself, request pid 5249
Apr 14 09:33:29 testing automount[5240]: failed to mount /cpy/users/myself
Apr 14 09:33:29 testing automount[5240]: attempting to mount entry /cpy/users/myself
Apr 14 09:33:29 testing automount[5240]: ioctl_send_fail: token = 137
Apr 14 09:33:29 testing automount[5240]: failed to mount /cpy/users/myself

There is no network traffic against the NFS server when this occurs.

I realize that it can be a bit difficult to know exactly what is wrong, but any suggestion is welcome.

share|improve this question
    
What happens when you try to mount the directory by hand, e.g. mkdir /tmp/myself; mount -t nfs4 server:/users/myself /tmp/myself? If it fails, can you run tcpdump during a mount attempt and post the relevant parts? What VM technology are you using, and what's your VM network topology? My first guesses would be firewalls or other obstacles to NFS or possibly portmap. –  justarobert Apr 14 '11 at 9:15
    
No, mounting myself's homedir by hand somewhere else in the VM works fine. It's a Xen HVM. –  Bittrance Apr 14 '11 at 11:47

2 Answers 2

up vote 1 down vote accepted

Gn! Answer to myself:

chmod -x /etc/auto.master /etc/auto.users

Problem solved. How's that for an obscure error message?

share|improve this answer

Try simplifying your /etc/auto.users file just a little:

*   -fstype=nfs4   server:/users/&

The rw flag should be controlled by the server export anyway, the tcp/port stuff should be left default unless you have specifically hacked it to be different.

share|improve this answer
1  
The & is necessary to reference whatever the wildcard in the first field matched, so that /cpy/users/foo maps to server:/users/foo. –  justarobert Apr 14 '11 at 9:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.