Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I can see this is rapidly becoming a FAQ.

Something is preventing me from accessing a shared folder via Webdav. Here are the steps taken so far:

0. Hosted machine has two IP addresses, 2 sub-domain names bound separately to each.
1. Add HTTPS binding to site using appcmd
2. Use netsh to bind SSL certificate.
3. Ensure 443 is open in the firewall
4. Installed desktop experience on server
5. Enabled webdav for site
6. Added virtual directory that maps to intended Webdav folder
7. Added Webdav authoring rule that gives read/write/modify access to me
8. Set webdav folder security properties give full control

I can access the root site and get verified HTTPS connection in Firefox. I cannot access the webdav folder from the server itself using net use * https://sub.domain.com/foldername. I get prompted for a username and password but the request fails with a 'system error 5', access is denied.

If I try and access using a browser I get an HTTP error 401.2 'invalid authentication headers'

If I try and access from a Windows 7 client I get the same access denied message.

Nothing unusual I can see in the server eventviewer, IIS logs are, umm, meaningless :)

This is driving me nuts. Any help welcomed.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

You haven't mentioned enabling an authentication scheme?

share|improve this answer
    
TK, thanks. please clue me in. –  G Forty Apr 15 '11 at 1:26
    
If you look in Authentication Methods, you'll always see Anonymous. If you've installed any other authentication schemes, they'll appear there too. In order for IIS to work out who you are in Windows terms, you'll need to (possibly install through Server Manager and) Enable at least one other Auth scheme. Windows Auth would be typical for WebDAV, but it depends on your user scenario (across the interwebs, perhaps Basic (in which case, consider SSL non-optional)) –  TristanK Apr 15 '11 at 3:31
    
Tristan, very helpful, thanks. I've now got Windows Authentication installed and it is the only auth method enabled for the webdav folder. Browsing to the webdav folder opens a username/password dialog but still access denied - any thoughts on this? However, I can access the webdav folder from a remote Windows 7 machine! For anyone else with this issue see here –  G Forty Apr 15 '11 at 10:59
    
Not quite understanding - was Windows auth installed before, or did you just install it? If we're talking about the difference between working remotely and locally on the server, you may need to look into DisableLoopBackCheck which is essentially protection from local reflection attacks. If it works from clients, I'm typically OK with that. –  TristanK Apr 16 '11 at 0:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.