Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Windows Server 2008 R2 HyperV machine. I had to restore it to an old snapshot, and now I'm getting the following error when logging in through remote desktop using a domain ID:

"the trust relationship between this workstation and the primary domain failed"

I tried running

netdom resetpwd / /ud:na\domainAdminId /pd:password

But it didn't help. I tried resetting the password and rebooting the server, but it didn't help.

Any ideas?

share|improve this question
and the basics work like nslookup fqdn? – tony roth Apr 14 '11 at 15:41

Try netdom reset :

share|improve this answer
did he edit and add the part about running netdom? – tony roth Apr 14 '11 at 15:40
@tony I don't know, but nedom reset != netdom resetpwd – Holocryptic Apr 14 '11 at 15:48
up vote 2 down vote accepted

The command I ran actually worked, it just took several minutes for it to take effect for some reason.

netdom resetpwd / /ud:na\domainAdminId /pd:password

I'm not sure why. I think somebody was rebooting some of the AD servers at the time I ran the command, so that could have thrown things off.

share|improve this answer
I used netdom resetpwd / /userd sysadminJoe /PasswordD * on the server which has a trust issue. (login to localhost) – Tilo Jan 11 at 22:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.