Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows Server 2008 R2 HyperV machine. I had to restore it to an old snapshot, and now I'm getting the following error when logging in through remote desktop using a domain ID:

"the trust relationship between this workstation and the primary domain failed"

I tried running

netdom resetpwd /s:server.company.lab /ud:na\domainAdminId /pd:password

But it didn't help. I tried resetting the password and rebooting the server, but it didn't help.

Any ideas?

share|improve this question
    
and the basics work like nslookup fqdn? –  tony roth Apr 14 '11 at 15:41

2 Answers 2

Try netdom reset : http://technet.microsoft.com/en-us/library/cc788073(WS.10).aspx

share|improve this answer
    
did he edit and add the part about running netdom? –  tony roth Apr 14 '11 at 15:40
    
@tony I don't know, but nedom reset != netdom resetpwd –  Holocryptic Apr 14 '11 at 15:48
up vote 2 down vote accepted

The command I ran actually worked, it just took several minutes for it to take effect for some reason.

netdom resetpwd /s:server.company.lab /ud:na\domainAdminId /pd:password

I'm not sure why. I think somebody was rebooting some of the AD servers at the time I ran the command, so that could have thrown things off.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.