Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having a problem accessing phpMyAdmin currently. This was the error that was posted in the error logs:

" PHP Warning: mysql_connect(): Access denied for user 'root'@'localhost' (using password: YES) in C:\UniServer\home\admin\www\mqsetup.php on line 64, referer: http://localhost/apanel/mqsetup.php "

So I would like to change it so that mySQL doesn't use a password. Any suggestions on how to do this???

Thanks in advance, I really appreciate this.

share|improve this question
    
    
@Shane -:) :) Not exactly...just trying out an alternative solution to the same underlying problem... This has been giving me trouble for a while unfortunately... –  Engprof Apr 14 '11 at 16:49
add comment

1 Answer

If PHPMyAdmin is automatically trying a set username and password to connect to a configured database then it must be in config authentication mode. The other common option requires you to specify a username and password to try and login with.

You need to change the PHPMyAdmin configuration (usually config.inc.php) in the PMA directory, either specify the correct login details or set it to cookie authentication so you can specify the correct details when you connect.

See also: http://wiki.phpmyadmin.net/pma/Auth_types

share|improve this answer
    
Thanks James, I'll try that and see how it goes. –  Engprof Apr 14 '11 at 16:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.