Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.
[root@myHost default]# ntpdate -d pool.ntp.org
15 Apr 11:21:18 ntpdate[6331]: ntpdate 4.2.0a@1.1190-r Thu Feb 24 20:39:57 EST 2011 (1)
Looking for host pool.ntp.org and service ntp
host found : magma.woody.ch
transmit(157.161.57.1)
transmit(157.161.57.1)
t    ransmit(157.161.57.1)
transmit(157.161.57.1)
transmit(157.161.57.1)
157.161.57.1: Server dropped: no data
server 157.161.57.1, port 123
stratum 0, precision 0, leap 00, trust 000
refid [157.161.57.1], delay 0.00000, dispersion 64.00000
transmitted 4, in filter 4
reference time:    00000000.00000000  Thu, Feb  7 2036  6:28:16.000
originate timestamp: 00000000.00000000  Thu, Feb  7 2036  6:28:16.000
transmit timestamp:  d152a8b1.9ca2ec28  Fri, Apr 15 2011 11:21:21.611
filter delay:  0.00000  0.00000  0.00000  0.00000
         0.00000  0.00000  0.00000  0.00000
filter offset: 0.000000 0.000000 0.000000 0.000000
         0.000000 0.000000 0.000000 0.000000
delay 0.00000, dispersion 64.00000
offset 0.000000

15 Apr 11:21:22 ntpdate[6331]: no server suitable for synchronization found

can someone please help me to understand what above means?

share|improve this question

2 Answers 2

The only server ntpdate found for update had a problem returning the date for your server. That can be some things:

  • If it was only this time, on this server, it could be a temporary issue and you should try again (since you are using pool.ntp.org and that points to various different servers);
  • If it happens with all the ntp servers you try, you can be behind a firewall that blocks ntp traffic or
  • You can have a bug or a config issue.
share|improve this answer
    
thanks for your help. my ntpd's version > version with the bug. i don't think i have any firewall enabled but with a local router's ip, ntpdate -b ip from command line works. when i added it to rc.local to run and reset the time each time the machine boots. it doesn't work. what's strange is if i do /etc/rc.local directly from the command line, it can work.. do you have any idea what may cause this behavior? thanks –  jasy Apr 15 '11 at 13:28
    
Is rc.local ran after the network is up? Why don't you put that on cron.daily or on a crontab instead of each boot? As a server, it's expected that the machine don't see a lot of boots anyway. –  coredump Apr 15 '11 at 13:50
    
Actually, I'm running into that problem a lot, and I noticed that every time I get this error, dispersion is 64. Less than that, no error. –  Daniel C. Sobral Jun 1 '11 at 20:25
    
If a command runs successfully from command line but not from a script such as rc.local (or cron, for instance) then my first suspect would be the PATH. Try writing it with full path in rc.local, it's also more secure. –  Amos Shapira Nov 28 '11 at 23:55

It means the server you are getting connected to either was not giving out the time (I just check it, it is working fine at this moment) or your network doesn't let you talk to it on the right ports. Maybe you are behind an overly restrictive firewall?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.