Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have Apache 2.2 running Subversion on my Win2k8 box. This has been setup for a few years like this.

The server has 1x NIC, with 2x IP addresses assigned, eg:

192.168.1.50
192.168.1.51

The 192.168.1.50 address is the primary NIC address. The 192.168.1.51 address is/was reserved for just apache.

Anyhow - Apache will now not start. After a debug, I found that the RRAS service in windows is now bound to port 443 on this IP, as well as the primary IP.

Can anyone please guide me as to how to prevent Windows RRAS from binding to this secondary IP address? If I stop the RRAS service, start Apache - all AOK. However, when the server reboots, RRAS is started first, and so Apache wont load.

This is new behaviour. I am at a loss to explain why - I just need to get it fixed.

share|improve this question

1 Answer 1

This is actually a common problem when you install RRAS and SSTP.

First run the following command to verify the RRAS is listening on all interfaces (0.0.0.0:443 or [::]:443) -
netsh http show sslcert
Note the certificate hash.

Next, remove the all bindings:
netsh http delete sslcert ipport=0.0.0.0:443
and
netsh http delete sslcert ipport=[::]:443

Then add the listener back on the correct interface (192.168.1.50):
netsh http add sslcert ipport=192.168.1.50:443 certhash=#HashFromAbove# appid={ba195980-cd49-458b-9e23-c84ee0adcd75} certstorename=MY

According to this article, you also have to insert the certificate hash in the SSTP service by editing the following registry key:
HKLM\System\CurrentControlSet\Services\Sstpsvc\Parameters\Sha256CertificateHash

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.