Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a vps (CentOS / xen) where I have setup openvpn server. I use this vpn to play games with my home computer.

Ive used these commands to configure iptables on the server (connexion is throught tcp 443) :

iptables -t nat -A PREROUTING --dst 10.9.0.0/24 -p tcp --dport 443 -j DNAT --to-destination 109.X.X.X
iptables -A FORWARD -m state --state RELATED,ESTABLISHED -j ACCEPT
iptables -A FORWARD -s 10.9.0.0/24 -j ACCEPT
iptables -t nat -A POSTROUTING -s 10.9.0.0/24 -o eth0 -j MASQUERADE

It works but game speed is enough slow and when i launch the game connection checker, it says :

  • You may get better results by enabling UPnP on your router.
  • You may get better results by adjusting the port forwarding settings on your router.
  • You may get better results by adjusting the firewall settings.
  • Please note that performance levels may differ when playing the game due to the effects of your personal firewall.

I think the firewall problem comme from my vps. I've tried a lot of iptables commands, but without success (Im not an expert with that...) I've even tried to allow all traffic by:

iptables -P OUTPUT ACCEPT
iptables -P INPUT ACCEPT
iptables -P FORWARD ACCEPT

How can I enable UPnP on a vps? Of course I've also tried to disable my client firewall.

share|improve this question
add comment

1 Answer 1

First, ensure that openvpn is using UDP not TCP, as that will allow openvpn to layer TCP/IP on top more efficiently.

It would be unwise to enable UPnP on a server - it's designed for home routers, and even there it has its security problems.

You haven't explained what port 443 is being used for, but I'm guessing it's for other gamers and/or gaming servers to make inbound connections to your computer. Is that right? If so, you might want to open up more ports. If not, you should probably open up at least one port and forward it along the VPN back to your computer.

share|improve this answer
1  
My ISP is blocking almost all ports except tcp 443, so its the only one i can use to connect client to vpn. Im the only one to use the vpn. –  chris Apr 15 '11 at 19:20
    
Ah yes, I had that same problem myself a few years ago. –  Robin Green Apr 15 '11 at 19:25
    
Ok and you have no solutions to improve speed ? (concerning firewall mainly) –  chris Apr 15 '11 at 19:43
    
Like I said, open up at least one port on the VPS and forward it back along the VPN to your computer. –  Robin Green Apr 15 '11 at 19:49
    
Can you give me the commands to do that plz... –  chris Apr 15 '11 at 19:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.