Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

What I was did before I restarted server: ran OpenEMM.sh start for installing OpenEMM.

This shouldn't have done anything to this mysql install.... I've tried to fix permissions, verified that plugin.frm is inface there.....

Any gurus out there got any ideas that would be helpful for me?

110416 00:00:25 mysqld_safe Starting mysqld.bin daemon with databases from /opt/bitnami/mysql/data
    ^G/opt/bitnami/mysql/bin/mysqld.bin: Can't find file: './mysql/plugin.frm' (errno: 13)
    110416  0:00:25 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
    110416  0:00:25  InnoDB: Operating system error number 13 in a file operation.
    InnoDB: The error means mysqld does not have the access rights to
    InnoDB: the directory.
    InnoDB: File name ./ibdata1
    InnoDB: File operation call: 'create'.
    InnoDB: Cannot continue operation.                                                                          
    110416 00:00:25 mysqld_safe mysqld from pid file /opt/bitnami/mysql/data/domU-12-31-38-04-61-21.pid ended
share|improve this question
1  
Didn't you try to run "mysql_upgrade" as the error says? –  HUB Apr 15 '11 at 18:45
1  
Why is mysql installed in /opt? Were you always using this version, and not the version packaged for ubuntu? –  Robin Green Apr 15 '11 at 18:54
    
Could you please specify which commands you're using to stop/start the server? If I remember correctly mysqld_safe has to be run from a specific path, and you generally don't use it directly. –  Eduardo Ivanec Apr 15 '11 at 19:30
    
has worked for months - Keep in mind that this might mean you haven't tested the startup procedure for months, and that many things might have changed during those months. It's the curse of high uptime. –  Stefan Lasiewski Apr 16 '11 at 3:26

2 Answers 2

Looks like the user running mysql does not have write-access to the directory where mysql is being started.

share|improve this answer

Ensure that the "mysql" folder is owned by use mysql. From the error logs its clear that mysql is unable to create a file in the "iblog" folder. This folder is usually inside mysql folder.

Stop the mysql server and run the following command and then restart it.

chown -R mysql /path_to/mysql
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.