Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I read the answers about 3306 from a question posted in 2009. I have the same problem, but the answers I read didn't help. Port 3306 is open, even if I stop the , MySQL still can't access it. MySQL is running. I've run netstat firewall xxxxxx and get these results:

3306   TCP       Enable   MySQL Server

and this from netstat -a -n:

TCP    [::]:3306              [::]:0                 LISTENING       0

(I don't understand the [::])

I do have AVG Internet Security running but not the Firewall component. How can I find out what is blocking MySQL from accessing this port? And it's not just this specific port, but any port. I've asked on the MySQL forum, but no one is replying.

share|improve this question
    
What does ipconfig /all shows? –  Vick Vega Apr 15 '11 at 18:58
    
Tunnel adapter Teredo Tunneling Pseudo-Interface: Connection-specific DNS Suffix . : Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface Physical Address. . . . . . . . . : FF-FF-FF-FF-FF-FF-FF-FF Dhcp Enabled. . . . . . . . . . . : No IP Address. . . . . . . . . . . . : fe80::ffff:ffff:fffxxx Default Gateway . . . . . . . . . : NetBIOS over Tcpip. . . . . . . . : Disabled –  Ron Apr 16 '11 at 1:15
add comment

5 Answers

Try bind-address=0.0.0.0 in my.ini Works on my PC.

share|improve this answer
    
I tried it but the config app just hung. –  Ron May 11 '11 at 12:05
    
Edit the my.ini file in Program Files\MySQL\MySQL Server X.Y and restart the MySQL Server. Add the bind-address to the [mysqld] section. I'm not using the config app. I'm assuming your problem is that you can't get the MySql client to connect to the MySql server? –  super May 11 '11 at 23:01
add comment

Here is a config snippet that should be informative:

[mysqld]

# The TCP/IP Port the MySQL Server will listen on
port=3306

# default IPv6,so change to ipv4 
bind-address = 0.0.0.0
share|improve this answer
1  
A bit more explanation would help –  Dave M Jul 1 '13 at 16:17
add comment

it means it is listening on ipv6 (thats why you can't connect to it with ipv4)

share|improve this answer
    
But, I didn't specify IPv4. There is no place to specify that. How do I change it back? –  Ron Apr 16 '11 at 0:57
    
For instance, under my Local Area Network, Microsoft TCP/IP Version 6 is checked. BUT, if I uncheck it won't I be cut off from IvP6 later on? Is there a way to restrict a port to IvP4? –  Ron Apr 16 '11 at 1:07
    
You to specify IPv4 address in order to connect to the server. –  Vick Vega Apr 16 '11 at 16:19
    
HOW do i do this? –  Ron Apr 16 '11 at 16:25
    
Can someone please tell me how to specify a port refers to IPv4 and not IPv6? –  Ron Apr 17 '11 at 4:09
add comment

There is also a bind-address setting in my.cnf which, if it is set to 127.0.0.1 (which is the default I believe), will prevent remote clients from connecting.

share|improve this answer
    
I am on Windows XP. I don't see any my.cnf. I have a my.ini but there is no bind-address setting there. –  Ron Apr 16 '11 at 1:01
    
my.ini is equivalent to my.cnf. I do not use Windows MySQL but it can't do any harm putting bind-address = a.b.c.d in it & restarting mysql, if the defaults are the same as Linux it might do the trick. If it doesn't then take it out, restart mysql again and try something else. –  blankabout Apr 16 '11 at 1:16
    
I should have said that a.b.c.d should be the IP address of your host. –  blankabout Apr 16 '11 at 1:18
    
bind-address=127.0.0.1 didn't help. –  Ron Apr 16 '11 at 13:28
    
I meant put bind-address=what the IP address of your host is, absolutely not 127.0.0.1 that will definitely stop it working! –  blankabout Apr 16 '11 at 13:53
show 3 more comments

jyoti Gurjar@:

go to Control Panel-->Network and internet Connection-->Change Firewall Setting--> Exceptions--> Add prt--> then type ,port name=MySql and port no.=3306. -->ok

:):):)

share|improve this answer
    
He has already mentioned that disabling the firewall does not work. –  MichelZ Jul 1 at 7:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.