Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How do you hide the domain clients from seeing one another in the Network Browser? I don't want to disable Network Discovery because I would like to be able to maintain them, access their administrative shares and run installations remotely.

This command does not work.

net config server /hidden:yes

How do you guys get around this?

share|improve this question

2 Answers 2

Disabling Computer Browser won't affect your ability to manage the systems remotely, just to see them in the network browser list.

Nuke the Computer Browser service and NetBIOS over TCP on the NIC or via DHCP with impunity.

share|improve this answer
    
Thanks Shane. I tested it on one of the machines with no luck. It still shows up on the network. Could it have something to do with the rest of them having CB and NetBIOS enabled? Meaning, do I need to disable it on the rest of them before I can see any results? –  Bourne Apr 15 '11 at 20:17

You mentioned that you disabled network discovery, that tells me that you're running Vista, 7, and/or W2K8. Are you running any W2K, W2K3, or WinXP machines?

For Vista, 7, and W2K8 disabling network discovery should be enough. I'm assuming that similar to previous versions of Windows that it will take time for the machines to drop out of network neighborhood/my network places just as it takes time for them to show up in network neighborhood/my network places so be patient.

share|improve this answer
    
Thanks Joe. Yes, Windows 7 clients in a 2008 environment. My previous experience has been that My Network Places usually populates pretty fast so I was expecting it to be "abandoned" just as fast. But I will give it some more time. –  Bourne Apr 15 '11 at 20:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.