Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running Windows Server 2008 with IIS7. On that server I have a third party RIA (Silverlight 3.0) application. When I am on the machine I can access the application via http://localhost/MyAppRIA and everything works as it should. When I try to access it via http://{Machine Name}/MyAppRIA I get a blank page with a Silverlight download graphic in the top left corner.

Why can I not access the application by using the machine name. Do I have a misconfiguration with my DNS or IIS?

share|improve this question
add comment

5 Answers

Assuming that the bindings are correct (Scott Forsyth answer offers some good information), it is possible you could be running into the infamous loopback check. Have a look at the following article:

http://support.microsoft.com/kb/896861

Specifically, look at 'Method 2: Disable the loopback check (less-recommended method)'. Many times this simple registry setting can cause some big headaches.

share|improve this answer
add comment

That's from the bindings in IIS. If you ping localhost (it will be 127.0.0.1) and {Machine Name}, they will be different IPs. Make sure to add a binding for the machine name IP (and optionally host header) for the site that you want it to bind to.

Here's a video I put together of IIS bindings that you may find helpful.

share|improve this answer
add comment

What happens when you access by IP address?
You can try using the equivalent of localhost by using:
http://127.0.0.1/MyAppRia

If that works then you could put the machine name into your localhosts file.
On Windows that is usually something like
\Windows\system32\drivers\etc\hosts

share|improve this answer
add comment

Don't. If it works from client machines, that's good enough.

share|improve this answer
add comment

Check the HTML using your browser's "view source" command. I bet the app has somehow hard-coded "localhost" into the paths, so when you look at it from another machine it's not able to download the assets it needs.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.