Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an IBM x3620 M3 server that has

root@web26:~# lshw -short
/0/100/9/0 scsi4 storage LSI MegaSAS 9260
/0/100/9/0/2.0.0 /dev/sda disk 1990GB ServeRAID M5015

hardware raid controller.

How do I view the RAID array status, SMART status and issue rebuild commands from Ubuntu for it?

PS.

root@web26:~# modinfo mptctl
filename:       /lib/modules/2.6.32-28-server/kernel/drivers/message/fusion/mptctl.ko
version:        3.04.12
license:        GPL
description:    Fusion MPT misc device (ioctl) driver
author:         LSI Corporation
srcversion:     9052501D1B37F5BF2F73C49
depends:        mptbase
vermagic:       2.6.32-28-server SMP mod_unload modversions
share|improve this question

migrated from stackoverflow.com Apr 16 '11 at 0:42

This question came from our site for professional and enthusiast programmers.

add comment

3 Answers

You'll need to install the MegaCLI package from LSI. The UI is rather complicated; you would do well to look around the web for cheat sheets and summaries.

share|improve this answer
    
@justarobet : Thank you, that worked! I am posting more detailed instruction below: –  Alec Matusis Apr 19 '11 at 1:50
add comment

That did it, thank you @justarobert. Here are the detailed instructions for the future:

# cat /etc/issue

Ubuntu 10.04.2 LTS \n \l

install two packages:

#apt-get install unzip rpm2cpio

unzip everything

#unzip 8.00.46_Linux_MegaCLI.zip
#unzip -d MegaCliLin MegaCliLin.zip
#unzip -d 8.00.46_Linux_MegaCLI 8.00.46_Linux_MegaCLI.zip

unpack RPMs (make sure you are in the right directory)

#rpm2cpio MegaCli-8.00.46-1.i386.rpm | cpio -idmv
#rpm2cpio Lib_Utils-1.00-08.noarch.rpm | cpio -idmv

(libsysfs.so.2.0.2 is required library, it comes from LSI in Lib_Utils-1.00-08.noarch.rpm, apt-get install libsysfs did not do it for me):

#cp opt/lsi/3rdpartylibs/x86_64/libsysfs.so.2.0.2 /usr/lib64/
#cp ./opt/MegaRAID/MegaCli/MegaCli64  /usr/local/sbin/
#ln -s /usr/local/sbin/MegaCli64 /usr/local/sbin/MegaCli

and voila, check RAID!

#  MegaCli -LDInfo -Lall -aALL
Adapter 0 -- Virtual Drive Information:
Virtual Drive: 0 (Target Id: 0)
Name                :
RAID Level          : Primary-1, Secondary-0, RAID Level Qualifier-0
Size                : 1.809 TB
**State               : Optimal**
Strip Size          : 128 KB
Number Of Drives    : 2
Span Depth          : 1
Default Cache Policy: WriteThrough, ReadAheadNone, Direct, No Write Cache if Bad BBU
Current Cache Policy: WriteThrough, ReadAheadNone, Direct, No Write Cache if Bad BBU
Access Policy       : Read/Write
Disk Cache Policy   : Disabled
Encryption Type     : None
Default Power Savings Policy: Controller Defined
Current Power Savings Policy: None
Can spin up in 1 minute: Yes
LD has drives that support T10 power conditions: No
LD's IO profile supports MAX power savings with cached writes: No
share|improve this answer
add comment

An update for the latest MegaCLI:

Get your packages. For example, the MegaRAID SAS9280-16i4e:

http://www.lsi.com/products/storagecomponents/Pages/MegaRAIDSAS9280-16i4e.aspx
-> Support & Downloads -> Management Tools

Install two packages:

  #sudo apt-get install unzip rpm2cpio
or
  #sudo apt-get install unzip alien #...overkill, but some nice utils

Unzip everything:

#cd to/your/dir/containing/8.02.16_MegaCLI
#unzip -d 8.02.16_Linux_MegaCLI 8.02.16_Linux_MegaCLI.zip
#cd 8.02.16_Linux_MegaCLI/LINUX
#unzip -d MegaCliLin MegaCliLin.zip

Unpack RPMs:

#cd MegaCliLin
#rpm2cpio MegaCli-8.02.16-1.i386.rpm | cpio -idmv

The library libsysfs.so.2.0.2 is "required". However, you may alternately use a native Ubuntu version with a soft link to fake out MegaCli:

  #rpm2cpio Lib_Utils-1.00-09.noarch.rpm | cpio -idmv
  #sudo cp opt/lsi/3rdpartylibs/x86_64/libsysfs.so.2.0.2 /usr/lib64/
or
  #sudo apt-get install libsysfs
  #locate libsysfs #...to get the proper filename
  #sudo ln -s /lib/libsysfs.so.2.0.1 /usr/lib64/libsysfs.so.2.0.2

#sudo cp opt/MegaRAID/MegaCli/MegaCli64 /usr/local/sbin/
#sudo ln -s /usr/local/sbin/MegaCli64 /usr/local/sbin/MegaCli

Check it, yo!

#sudo MegaCli -AdpAllInfo -aALL
#sudo MegaCli -LDInfo -Lall -aALL
#sudo MegaCli -PDList -aALL
share|improve this answer
    
Worked on Ubuntu 10.04. The zip file seems to be named 8.02.16_MegaCLI.zip, and the libsysfs package name is libsysfs2. –  jarnoan Jan 2 '12 at 9:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.