Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a headless windows server 2008 R2 running, and obviously I forgot to enable remote administration. Every attempt to connect via remote desktop, even with the administrator user, is currently rejected because remote desktop isn't licenced. Which is correct, because I don't need it on that mashine, just should be able to configure the system from time to time.

So I'm a bit lazy: I don't want to shut down the system, carry it over to some place with monitor and keyboard, change the configuration, shut it down again and carry it back.

Is there a way to remotely connect to the machine and activate the remote administration via network, so that I can connect again?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

It sounds like you've installed the Remote Desktop Services role (formerly known as "Terminal Services in Application Mode"), the 60-days grace period has passed and you are lacking a Licensing Server. Although I'd think that even in this case you should be able to connect and log on as a member of the Administrators group regardless of your licensing status, there are some things you might want to try:

  • use the /admin option when calling mstsc to make sure you are opening an administrative connection - e.g. mstsc.exe /v:yourServerName /admin
  • check via remote registry access if fDenyTSConnections (google up that one, I am not allowed to post more hyperlinks due to this "great" serverfault.com feature) is set to 0 on your server
  • uninstall the Remote Desktop Services role using the command line remotely executed with psexec (you'll have to google on this one as well)
share|improve this answer
    
Using the /admin command on mstsc works like a charm. –  Sebastian P.R. Gingter Apr 16 '11 at 13:38
    
Glad to hear that. Happy coding. –  the-wabbit Apr 16 '11 at 13:45

You can do this easily by running your regedit on any PC on the same subnet. Connect to the Remote Registry, select the target server and Edit the HKLM\System\Control\CurrentControlSet\Terminal Server which has a key fDenyTSConnections value from 1 to 0.

You will need to reboot the remote machine in order for this to take effect, so on the same machine you ran regedit load a command line and issue the shutdown command targeting the remote machine using the -r switch.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.