Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm not sure it's the right section to be asking this question, sorry if it's not.

Last night I used openSUSE ImageWriter to create a USB bootable flash driver, however the drive is completely unusable at the moment, it reports 0b.

I tried cfdisk, fdisk, parted and I even tried dd if=/dev/zero of=/dev/sdc bs=1024 count=100 and I ended up with dd exiting with 0b written and an error message No space left on device.

It seems that the USB pen has lost track of it's storage, is there any way to fix it? or should I just throw it ?

Thanks

share|improve this question

1 Answer 1

You can try to use fdisk and recreate its partitions. I have seen usb flash drivers miraculously being fixed after being formated by Windows, so you may want to try that too.

share|improve this answer
1  
The problem is that I tried fdisk, but it reports no media found and exits.. It's like the USB flash driver has no media at all, worse it's recognised as Generic USB drive instead of PTY... –  eMxyzptlk Apr 19 '11 at 9:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.