Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On Kittara.com/Supertest.PHP I have a basic HTML page (The home page is simply an image). But I planned on putting PHP in it so I renamed it to .PHP On doing so it causes a 500 Internal Server error.

Error.log says:

[client 96.244.40.64] Premature end of script headers: home.PHP, referer: http://66.135.33.210/
[client 96.244.40.64] SoftException in Application.cpp:363: GID of script "/usr/local/apache/htdocs/home.PHP" is smaller than min_gid, referer: http://66.135.33.210/

Here is the code for Supertest.PHP:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">


<HTML>
    <head>
        <style type="text/css">
            body{
                width:99%;
                height:99%; 

            }
            #nexuss {
                margin-top:10%;
                margin-right:25%;
                margin-left: 42%;
                height:99%; 
            }
        </style>
    </head>
    <body>

    <div id="nexuss"><img src="nexus s.png" alt="" width="258" height="516" /></div>
    </body>
</HTML>

Maybe it's because I don't have a .htaccess?

share|improve this question
add comment

2 Answers 2

It appears that you are running PHP via the suPHP tool. One of the configuration options for suPHP is the minimum GID that a PHP script is allowed to run under. The GID of your scripts is below that minimum value.

You will have to either change the group ownership of the files or change the min_gid value in suphp.conf.

share|improve this answer
add comment

That's a suexec or suphp error.

The path /usr/local/apache/htdocs/home.php also indicates that the file is not owned by an ordinary user.

Solution: Change the script owner from root to an ordinary user account. Better yet, create a virtualhost documentroot elsewhere and chown it to an user.

If the error still persists, you must adapt the mentioned min_gid setting. It's often > 1000 or something.

share|improve this answer
    
I tried this, my user account owns apache and all files and sub directories –  Michael Apr 17 '11 at 18:54
    
That's what it should not do. Create a new user with a higher gid/uid >1000, and test it with that. –  mario Apr 17 '11 at 18:58
    
How do I do that? –  Michael Apr 17 '11 at 19:25
    
addgroup --gid 5005 testgroup and adduser --gid 5005 --firstuid 7007 testuser –  mario Apr 17 '11 at 19:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.