Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've installed the new version of SquirrelMail 1.4.21 on my server. The old version is working fine. The new version is working fine with IE and Firefox. But in Google Chrome, after login, when I try to open any email from the inbox it returns this error:

ERROR
You must be logged in to access this page.
Go to the login page

This is the VirtualHost configuration for SquirrelMail:

<VirtualHost *:80>
DocumentRoot /www/webmail2.zedandzed.com
ServerName webmail2.zedandzed.com
ErrorDocument 403 http://webmail2.zedandzed.com/index.php
ErrorDocument 404 http://webmail2.zedandzed.com/index.php
ErrorDocument 405 http://webmail2.zedandzed.com/index.php
php_value session.auto_start 0
#php_value register_globals off
php_value magic_quotes_gpc off
php_value session.use_cookies 1

<Directory "/www/webmail2.zedandzed.com">
Options Indexes FollowSymLinks ExecCGI Includes MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>

</VirtualHost>

Why is it not working in Google Chrome?

share|improve this question

3 Answers 3

Got it fixed. It was for the "php_value session.use_cookies 1". I've put the "session.use_cookies" value from "1" to "0".

share|improve this answer

This sounds like it's a problem with cookies in your browser. Squirrelmail keeps track of your login status by saving a cookie, and if it's not present, then you're not logged in.

share|improve this answer
    
Have allowed cookies and flushed all previous cookies. Still the same. –  Saif Apr 19 '11 at 6:00

Flush your cookies / saved login credentials relative to that site in Chrome. It sounds like you got a dud saved in there and it's not allowing it to set a new one. Alternatively, figure out the link to the "logout" system (you will have to do this manually since the link isn't exposed when you are not logged in) and try to have to SM clean things up ready for a fresh login.

share|improve this answer
    
I've flushed all cookies from google Chrome. Still returning the same error. –  Saif Apr 19 '11 at 5:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.