Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So whenever I connect either my Windows 7 computer, or Windows Server 2008 R2 server to an SSTP VPN running on a Windows Server 2008 R2 box, I lose internet connection. One suggestion I got was, on the client side, open the VPN properties, go to Networking, IPv4, Advanced, DNS tab, and uncheck "Register this connection's address in DNS". But even with doing that, I still don't have much of an internet connection to browse the web or ping a website such as Google.

Any idea what I can do to fix this?

Thanks!

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Are you routing all the traffic in the tunnel? That could be your problem.

This could solve your problem...

The answer that was accepted seemed a plausible solution to what you are describing.

You can turn off taking over your entire connection by going to the properties of the VPN, Networking tab, "Internet Protocol (TCP/IP)" properties, Advanced, untick "Use default gateway on remote network". This may or may not leave a route to 192.168.123.0/24 depending on the VPN server's setup. If it doesn't, you'll have to manually add the route each time, although you could put it in a batch file.

share|improve this answer
    
Woo, worked like a dream. Thanks much mate. –  Chiggins Apr 18 '11 at 20:23
    
Thanks a lot ! This is so trivial, though I had to go through dozens of pages to find this one. –  Luk Sep 6 '12 at 20:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.