Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am working from this document in trying to install mod_jk

http://www.howtoforge.com/apache2_tomcat5_mod_jk_p2

I am at the step towards the bottom where they suggest to use the make command. I was trying to use make like this and got an error:

/usr/src/jakarta-tomcat-connectors-1.2.15-src/jk/native$ sudo make mod_jk
make: *** No rule to make target `mod_jk'.  Stop. 

What is the proper way to execute this command? I am concerned that article may have outdated information. Is this still the right way to do things?

share|improve this question
    
Are you following instructions, or do you understand the process that is going on in order for the Makefile to work? If it's the latter, you'll be able to solve your own problem. –  Tom O'Connor Apr 18 '11 at 21:37
    
@Tom I am trying to follow the instructions, and not sure what the exact process is to get all the needed components to work...kind of in mod_jk hell right now :) –  Genadinik Apr 18 '11 at 22:10
    
What distro are you on? –  Tom O'Connor Apr 18 '11 at 22:18
    
@Tom I am on Ubuntu 10.04.2 –  Genadinik Apr 18 '11 at 22:59
add comment

1 Answer

up vote 2 down vote accepted

Given that you're using Ubuntu 10.04, have you tried sudo apt-get install libapache2-mod-jk?

That should work, and then all you need to do is sudo a2enmod jk and sudo /etc/init.d/apache2 restart

And it should work..

share|improve this answer
    
Wow that was pretty amazing. I googled so much for the answer and you just got it boom! Totally seemed to work since the installation messages ran by. What is a good way to test that it actually worked by the way? –  Genadinik Apr 18 '11 at 23:34
1  
Check /etc/apache2/mods-available for something that looks like mod_jk.conf and mod_jk.load or possibly just jk.conf / jk.load –  Tom O'Connor Apr 18 '11 at 23:54
    
I have just this: -rw-r--r-- 1 root root 56 2009-11-06 15:10 jk.load - why would it say from 2009? Thanks! –  Genadinik Apr 19 '11 at 0:03
1  
ls is showing you the file's mtime (the last time it was modified) which is probably when the package was built. If you wanna see it's creation time (ctime), do ls -lahc jk* and it'll say something like -rw-r--r-- 1 root root 56 2011-04-19 11:02 jk.load –  Tom O'Connor Apr 19 '11 at 10:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.